summaryrefslogtreecommitdiff
path: root/Build/source/libs/harfbuzz/harfbuzz-src/src/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/libs/harfbuzz/harfbuzz-src/src/meson.build')
-rw-r--r--Build/source/libs/harfbuzz/harfbuzz-src/src/meson.build37
1 files changed, 31 insertions, 6 deletions
diff --git a/Build/source/libs/harfbuzz/harfbuzz-src/src/meson.build b/Build/source/libs/harfbuzz/harfbuzz-src/src/meson.build
index 90735cb7e9b..4d63ecf90ae 100644
--- a/Build/source/libs/harfbuzz/harfbuzz-src/src/meson.build
+++ b/Build/source/libs/harfbuzz/harfbuzz-src/src/meson.build
@@ -324,6 +324,19 @@ hb_glib_headers = files('hb-glib.h')
hb_graphite2_sources = files('hb-graphite2.cc')
hb_graphite2_headers = files('hb-graphite2.h')
+hb_wasm_sources = files(
+ 'hb-wasm-api.cc',
+ 'hb-wasm-api.hh',
+ 'hb-wasm-api-blob.hh',
+ 'hb-wasm-api-buffer.hh',
+ 'hb-wasm-api-common.hh',
+ 'hb-wasm-api-face.hh',
+ 'hb-wasm-api-font.hh',
+ 'hb-wasm-api-shape.hh',
+ 'hb-wasm-shape.cc',
+)
+hb_wasm_headers = files()
+
# System-dependent sources and headers
hb_coretext_sources = files('hb-coretext.cc')
@@ -353,11 +366,10 @@ hb_subset_sources = files(
'hb-subset-cff-common.cc',
'hb-subset-cff-common.hh',
'hb-subset-cff1.cc',
- 'hb-subset-cff1.hh',
'hb-subset-cff2.cc',
- 'hb-subset-cff2.hh',
'hb-subset-input.cc',
'hb-subset-input.hh',
+ 'hb-subset-instancer-solver.hh',
'hb-subset-instancer-solver.cc',
'hb-subset-plan.cc',
'hb-subset-plan.hh',
@@ -417,7 +429,7 @@ custom_target('harfbuzz.cc',
output: 'harfbuzz.cc',
input: hb_base_sources + hb_glib_sources + hb_ft_sources +
hb_graphite2_sources + hb_uniscribe_sources + hb_gdi_sources +
- hb_directwrite_sources + hb_coretext_sources,
+ hb_directwrite_sources + hb_coretext_sources + hb_wasm_sources,
command: [find_program('gen-harfbuzzcc.py'),
'@OUTPUT@', meson.current_source_dir(), '@INPUT@'],
)
@@ -460,6 +472,13 @@ if conf.get('HAVE_GRAPHITE2', 0) == 1
harfbuzz_deps += [graphite2_dep, graphite_dep]
endif
+if conf.get('HAVE_WASM', 0) == 1
+ hb_sources += hb_wasm_sources
+ hb_headers += hb_wasm_headers
+ harfbuzz_deps += wasm_dep
+ #harfbuzz_deps += llvm_dep
+endif
+
if conf.get('HAVE_UNISCRIBE', 0) == 1
hb_sources += hb_uniscribe_sources
hb_headers += hb_uniscribe_headers
@@ -497,6 +516,7 @@ features = [
'GRAPHITE',
'ICU',
'UNISCRIBE',
+ 'WASM',
]
hb_enabled_features = configuration_data()
@@ -700,6 +720,8 @@ if get_option('tests').enabled()
'test-unicode-ranges': ['test-unicode-ranges.cc'],
'test-vector': ['test-vector.cc', 'hb-static.cc'],
'test-bimap': ['test-bimap.cc', 'hb-static.cc'],
+ 'test-instancer-solver': ['test-subset-instancer-solver.cc', 'hb-subset-instancer-solver.cc', 'hb-static.cc'],
+ 'test-tuple-varstore': ['test-tuple-varstore.cc', 'hb-subset-instancer-solver.cc', 'hb-static.cc'],
}
foreach name, source : compiled_tests
if cpp.get_argument_syntax() == 'msvc' and source.contains('hb-static.cc')
@@ -846,7 +868,7 @@ if have_gobject
if build_gir
conf.set('HAVE_INTROSPECTION', 1)
- hb_gen_files_gir = gnome.generate_gir(libharfbuzz_gobject,
+ hb_gen_files_gir = gnome.generate_gir([libharfbuzz_gobject, libharfbuzz],
sources: [gir_headers, gir_sources, gobject_enums_h],
dependencies: libharfbuzz_dep,
namespace: 'HarfBuzz',
@@ -854,7 +876,7 @@ if have_gobject
identifier_prefix: 'hb_',
symbol_prefix: ['hb', 'hb_gobject'],
includes: ['GObject-2.0', 'freetype2-2.0'],
- export_packages: ['harfbuzz-gobject'],
+ export_packages: ['harfbuzz-gobject', 'harfbuzz'],
header: 'hb-gobject.h',
install: true,
extra_args: ['--cflags-begin',
@@ -910,7 +932,10 @@ if get_option('tests').enabled()
env.set('HBHEADERS', ' '.join(HBHEADERS))
if cpp.get_argument_syntax() != 'msvc' and not meson.is_cross_build() # ensure the local tools are usable
- dist_check_script += ['check-libstdc++', 'check-static-inits', 'check-symbols']
+ dist_check_script += ['check-static-inits', 'check-symbols']
+ if get_option('wasm').disabled()
+ dist_check_script += ['check-libstdc++']
+ endif
endif
foreach name : dist_check_script