summaryrefslogtreecommitdiff
path: root/Build/source/libs/harfbuzz/harfbuzz-src/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/libs/harfbuzz/harfbuzz-src/meson.build')
-rw-r--r--Build/source/libs/harfbuzz/harfbuzz-src/meson.build29
1 files changed, 21 insertions, 8 deletions
diff --git a/Build/source/libs/harfbuzz/harfbuzz-src/meson.build b/Build/source/libs/harfbuzz/harfbuzz-src/meson.build
index 5dd936ced75..3e64cba2d7a 100644
--- a/Build/source/libs/harfbuzz/harfbuzz-src/meson.build
+++ b/Build/source/libs/harfbuzz/harfbuzz-src/meson.build
@@ -1,6 +1,6 @@
project('harfbuzz', 'c', 'cpp',
meson_version: '>= 0.55.0',
- version: '3.2.0',
+ version: '3.4.0',
default_options: [
'cpp_rtti=false', # Just to support msvc, we are passing -fno-exceptions also anyway
'cpp_std=c++11',
@@ -57,10 +57,17 @@ if host_machine.cpu_family() == 'arm' and cpp.alignment('struct { char c; }') !=
endif
endif
+if host_machine.system() == 'windows'
+ add_project_arguments(cpp.get_supported_arguments([
+ '-Wa,-mbig-obj'
+ ]), language : 'cpp')
+endif
+
check_headers = [
['unistd.h'],
['sys/mman.h'],
['stdbool.h'],
+ ['xlocale.h'],
]
check_funcs = [
@@ -70,6 +77,8 @@ check_funcs = [
['getpagesize'],
['mmap'],
['isatty'],
+ ['uselocale'],
+ ['newlocale'],
]
m_dep = cpp.find_library('m', required: false)
@@ -87,15 +96,12 @@ if not get_option('freetype').disabled()
if not freetype_dep.found()
# https://github.com/harfbuzz/harfbuzz/pull/2498
freetype_dep = dependency('freetype2', required: get_option('freetype'),
- fallback: ['freetype2', 'freetype_dep'],
default_options: ['harfbuzz=disabled'])
endif
endif
-glib_dep = dependency('glib-2.0', required: get_option('glib'),
- fallback: ['glib', 'libglib_dep'])
-gobject_dep = dependency('gobject-2.0', required: get_option('gobject'),
- fallback: ['glib', 'libgobject_dep'])
+glib_dep = dependency('glib-2.0', required: get_option('glib'))
+gobject_dep = dependency('gobject-2.0', required: get_option('gobject'))
graphite2_dep = dependency('graphite2', required: get_option('graphite2'))
graphite_dep = dependency('graphite2', required: get_option('graphite'))
@@ -123,6 +129,13 @@ if not get_option('icu').disabled()
endif
endif
+if icu_dep.found() and icu_dep.type_name() == 'pkgconfig'
+ icu_defs = icu_dep.get_variable(pkgconfig: 'DEFS', default_value: '')
+ if icu_defs != ''
+ add_project_arguments(icu_defs, language: ['c', 'cpp'])
+ endif
+endif
+
cairo_dep = null_dep
cairo_ft_dep = null_dep
if not get_option('cairo').disabled()
@@ -145,8 +158,8 @@ if not get_option('cairo').disabled()
# dependency cycle here because we have configured freetype2 above with
# harfbuzz support disabled, so when cairo will lookup freetype2 dependency
# it will be forced to use that one.
- cairo_dep = dependency('cairo', fallback: 'cairo', required: get_option('cairo'))
- cairo_ft_dep = dependency('cairo-ft', fallback: 'cairo', required: get_option('cairo'))
+ cairo_dep = dependency('cairo', required: get_option('cairo'))
+ cairo_ft_dep = dependency('cairo-ft', required: get_option('cairo'))
endif
endif