summaryrefslogtreecommitdiff
path: root/Build/source/libs/harfbuzz/harfbuzz-src/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/libs/harfbuzz/harfbuzz-src/meson.build')
-rw-r--r--Build/source/libs/harfbuzz/harfbuzz-src/meson.build41
1 files changed, 11 insertions, 30 deletions
diff --git a/Build/source/libs/harfbuzz/harfbuzz-src/meson.build b/Build/source/libs/harfbuzz/harfbuzz-src/meson.build
index cd7acff249f..53b721febe4 100644
--- a/Build/source/libs/harfbuzz/harfbuzz-src/meson.build
+++ b/Build/source/libs/harfbuzz/harfbuzz-src/meson.build
@@ -1,6 +1,6 @@
project('harfbuzz', 'c', 'cpp',
- meson_version: '>= 0.52.0',
- version: '3.1.1',
+ meson_version: '>= 0.55.0',
+ version: '3.1.2',
default_options: [
'cpp_rtti=false', # Just to support msvc, we are passing -fno-exceptions also anyway
'cpp_std=c++11',
@@ -141,18 +141,12 @@ if not get_option('cairo').disabled()
endif
if not cairo_dep.found()
- # Requires Meson 0.54.0 to use cairo subproject
- if meson.version().version_compare('>=0.54.0')
- # Note that we don't have harfbuzz -> cairo -> freetype2 -> harfbuzz fallback
- # dependency cycle here because we have configured freetype2 above with
- # harfbuzz support disabled, so when cairo will lookup freetype2 dependency
- # it will be forced to use that one.
- cairo_dep = dependency('cairo', fallback: 'cairo', required: get_option('cairo'))
- cairo_ft_dep = dependency('cairo-ft', fallback: 'cairo', required: get_option('cairo'))
- elif get_option('cairo').enabled()
- error('cairo feature is enabled but it cannot be found on the system and ' +
- 'meson>=0.54.0 is required to build it as subproject')
- endif
+ # Note that we don't have harfbuzz -> cairo -> freetype2 -> harfbuzz fallback
+ # dependency cycle here because we have configured freetype2 above with
+ # harfbuzz support disabled, so when cairo will lookup freetype2 dependency
+ # it will be forced to use that one.
+ cairo_dep = dependency('cairo', fallback: 'cairo', required: get_option('cairo'))
+ cairo_ft_dep = dependency('cairo-ft', fallback: 'cairo', required: get_option('cairo'))
endif
endif
@@ -387,19 +381,6 @@ build_summary = {
'Benchmark': get_option('benchmark').enabled(),
},
}
-if meson.version().version_compare('>=0.53')
- foreach section_title, section : build_summary
- summary(section, bool_yn: true, section: section_title)
- endforeach
-else
- summary = ['']
- foreach section_title, section : build_summary
- summary += ' @0@:'.format(section_title)
- foreach feature, value : section
- summary += ' @0@:'.format(feature)
- summary += ' @0@'.format(value)
- endforeach
- summary += ''
- endforeach
- message('\n'.join(summary))
-endif
+foreach section_title, section : build_summary
+ summary(section, bool_yn: true, section: section_title)
+endforeach