summaryrefslogtreecommitdiff
path: root/Build/source/libs/harfbuzz/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/libs/harfbuzz/Makefile.am')
-rw-r--r--Build/source/libs/harfbuzz/Makefile.am38
1 files changed, 23 insertions, 15 deletions
diff --git a/Build/source/libs/harfbuzz/Makefile.am b/Build/source/libs/harfbuzz/Makefile.am
index d469e36914d..5479ae821d5 100644
--- a/Build/source/libs/harfbuzz/Makefile.am
+++ b/Build/source/libs/harfbuzz/Makefile.am
@@ -8,10 +8,6 @@
##
ACLOCAL_AMFLAGS = -I ../../m4
-# Rebuild
-.PHONY: rebuild
-rebuild: all
-
## We want to re-distribute the whole original harfbuzz source tree.
##
EXTRA_DIST = $(HARFBUZZ_TREE)
@@ -117,24 +113,36 @@ libharfbuzz_a_SOURCES += @HARFBUZZ_TREE@/src/hb-graphite2.cc
$(libharfbuzz_a_OBJECTS): config.force
-config.force: $(libharfbuzz_dependencies)
- echo timestamp >config.force
- $(SHELL) ./config.status --recheck
+if build
+check_PROGRAMS = hbtest
+dist_check_SCRIPTS = harfbuzz.test
+TESTS = harfbuzz.test
+endif build
+
+hbtest_SOURCES = hbtest.c
+
+# Force Automake to use CXXLD for linking
+nodist_EXTRA_hbtest_SOURCES = dummy.cxx
-DISTCLEANFILES = config.force
+hbtest_CPPFLAGS = -Iinclude $(ICU_INCLUDES) $(GRAPHITE2_INCLUDES)
+
+LDADD = libharfbuzz.a $(ICU_LIBS) $(GRAPHITE2_LIBS)
## Rebuild libsicuxxx
@ICU_RULE@
## Rebuild libgraphite2
@GRAPHITE2_RULE@
-##if build
-## check_PROGRAMS =
-## dist_check_SCRIPTS = harfbuzz.test
-## TESTS = harfbuzz.test
-## endif build
+# Reconfig
+reconfig_prereq = $(libharfbuzz_dependencies)
+DISTCLEANFILES =
+
+include $(srcdir)/../../am/reconfig.am
-LDADD = libharfbuzz.a
+# Rebuild
+rebuild_prereq =
+rebuild_target = all
+CLEANFILES =
-## Files generated by TESTS
+include $(srcdir)/../../am/rebuild.am