summaryrefslogtreecommitdiff
path: root/Build/source/libs/gd/libgd-2.1.0/tests/gd2/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/libs/gd/libgd-2.1.0/tests/gd2/CMakeLists.txt')
-rw-r--r--Build/source/libs/gd/libgd-2.1.0/tests/gd2/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/Build/source/libs/gd/libgd-2.1.0/tests/gd2/CMakeLists.txt b/Build/source/libs/gd/libgd-2.1.0/tests/gd2/CMakeLists.txt
new file mode 100644
index 00000000000..c9bd5e5876e
--- /dev/null
+++ b/Build/source/libs/gd/libgd-2.1.0/tests/gd2/CMakeLists.txt
@@ -0,0 +1,14 @@
+
+SET(TESTS_FILES
+ gd2_read
+ gd2_empty_file
+ gd2_im2im
+ gd2_null
+)
+
+FOREACH(test_name ${TESTS_FILES})
+ add_executable(${test_name} "${test_name}.c")
+ target_link_libraries (${test_name} gdTest)
+ get_target_property(test_path ${test_name} LOCATION)
+ ADD_TEST(${test_name} ${test_path})
+ENDFOREACH(test_name)