summaryrefslogtreecommitdiff
path: root/Build/source/libs/gd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/libs/gd/Makefile.am')
-rw-r--r--Build/source/libs/gd/Makefile.am95
1 files changed, 95 insertions, 0 deletions
diff --git a/Build/source/libs/gd/Makefile.am b/Build/source/libs/gd/Makefile.am
new file mode 100644
index 00000000000..9d4b46e0c15
--- /dev/null
+++ b/Build/source/libs/gd/Makefile.am
@@ -0,0 +1,95 @@
+## Proxy Makefile.am to build libpng for TeX Live.
+##
+## Copyright (C) 2009 Peter Breitenlohner <tex-live@tug.org>
+##
+## This file is free software; the copyright holder
+## gives unlimited permission to copy and/or distribute it,
+## with or without modifications, as long as this notice is preserved.
+##
+ACLOCAL_AMFLAGS = -I ../../m4
+
+## We want to re-distribute the whole original libpng source tree.
+##
+## With current automake (1.10.2) 'make distcheck' fails when
+## DISTFILES contains a directory and files in that directory.
+## Thus nodist_* for all files in $(GD_TREE).
+EXTRA_DIST = $(GD_TREE)
+
+INCLUDES = -I$(top_srcdir)/$(GD_TREE) $(ZLIB_INCLUDES) $(LIBPNG_INCLUDES)
+
+if build
+
+noinst_LIBRARIES=libgd.a
+
+endif build
+
+nodist_libgd_a_SOURCES = \
+ $(GD_TREE)/gd.c \
+ $(GD_TREE)/gd_gd.c \
+ $(GD_TREE)/gd_gd2.c \
+ $(GD_TREE)/gd_gif_in.c \
+ $(GD_TREE)/gd_gif_out.c \
+ $(GD_TREE)/gd_io.c \
+ $(GD_TREE)/gd_io_dp.c \
+ $(GD_TREE)/gd_io_file.c \
+ $(GD_TREE)/gd_io_ss.c \
+ $(GD_TREE)/gd_jpeg.c \
+ $(GD_TREE)/gd_png.c \
+ $(GD_TREE)/gd_security.c \
+ $(GD_TREE)/gd_ss.c \
+ $(GD_TREE)/gd_topal.c \
+ $(GD_TREE)/gd_wbmp.c \
+ $(GD_TREE)/gdcache.c \
+ $(GD_TREE)/gdfontg.c \
+ $(GD_TREE)/gdfontl.c \
+ $(GD_TREE)/gdfontmb.c \
+ $(GD_TREE)/gdfonts.c \
+ $(GD_TREE)/gdfontt.c \
+ $(GD_TREE)/gdft.c \
+ $(GD_TREE)/gdfx.c \
+ $(GD_TREE)/gdhelpers.c \
+ $(GD_TREE)/gdkanji.c \
+ $(GD_TREE)/gdtables.c \
+ $(GD_TREE)/gdxpm.c \
+ $(GD_TREE)/wbmp.c
+
+BUILT_SOURCES = \
+ entities.h \
+ gd.h \
+ gd_io.h \
+ gdcache.h \
+ gdfontg.h \
+ gdfontl.h \
+ gdfontmb.h \
+ gdfonts.h \
+ gdfontt.h \
+ gdfx.h \
+ gdhelpers.h \
+ jisx0208.h \
+ wbmp.h
+
+$(BUILT_SOURCES): stamp-gd
+
+libgd_a_DEPENDENCIES = $(ZLIB_DEPEND) $(LIBPNG_DEPEND)
+
+## Rebuild zlib
+@ZLIB_RULE@
+## Rebuild libpng
+@LIBPNG_RULE@
+
+stamp-gd:
+ @for file in $(built_sources); do \
+ test -f $$file || { \
+ echo "$(LN_S) $(srcdir)/$(GD_TREE)/$$file $$file"; \
+ $(LN_S) $(srcdir)/$(GD_TREE)/$$file $$file; } || exit 1; \
+ done
+ echo timestamp >$@
+
+distclean-local:
+ rm -f stamp-gd $(BUILT_SOURCES)
+
+## Eventually delete these files
+##
+
+EXTRA_DIST += Makefile.in.orig configure.in.orig
+