summaryrefslogtreecommitdiff
path: root/Build/source/libs/freetype2/freetype-src/builds/unix/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/libs/freetype2/freetype-src/builds/unix/configure.ac')
-rw-r--r--Build/source/libs/freetype2/freetype-src/builds/unix/configure.ac19
1 files changed, 6 insertions, 13 deletions
diff --git a/Build/source/libs/freetype2/freetype-src/builds/unix/configure.ac b/Build/source/libs/freetype2/freetype-src/builds/unix/configure.ac
index 393ec3bb69a..a98865a432d 100644
--- a/Build/source/libs/freetype2/freetype-src/builds/unix/configure.ac
+++ b/Build/source/libs/freetype2/freetype-src/builds/unix/configure.ac
@@ -2,7 +2,7 @@
#
# Process this file with autoconf to produce a configure script.
#
-# Copyright (C) 2001-2022 by
+# Copyright (C) 2001-2023 by
# David Turner, Robert Wilhelm, and Werner Lemberg.
#
# This file is part of the FreeType project, and may only be used, modified,
@@ -11,13 +11,13 @@
# indicate that you have read the license and understand and accept it
# fully.
-AC_INIT([FreeType], [2.12.1], [freetype@nongnu.org], [freetype])
+AC_INIT([FreeType], [2.13], [freetype@nongnu.org], [freetype])
AC_CONFIG_SRCDIR([ftconfig.h.in])
# Don't forget to update `docs/VERSIONS.TXT'!
-version_info='24:3:18'
+version_info='25:0:19'
AC_SUBST([version_info])
ft_version=`echo $version_info | tr : .`
AC_SUBST([ft_version])
@@ -50,7 +50,7 @@ if test ${cross_compiling} = yes; then
AC_MSG_CHECKING([for suffix of native executables])
rm -f a.* b.* a_out.exe conftest.*
- echo > conftest.c "int main() { return 0;}"
+ echo > conftest.c "int main(void) { return 0;}"
${CC_BUILD} conftest.c || AC_MSG_ERROR([native C compiler is not working])
rm -f conftest.c
if test -x a.out -o -x b.out -o -x conftest; then
@@ -163,9 +163,6 @@ fi
AC_SUBST([FTSYS_SRC])
-AC_CHECK_FUNCS([memcpy memmove])
-
-
# get compiler flags right
#
# We try to make the compiler work for C99-strict source. Even if the
@@ -406,16 +403,12 @@ if test x"$with_png" = xyes -o x"$with_png" = xauto; then
have_libpng="yes (LIBPNG_CFLAGS and LIBPNG_LIBS)"
else
# fall back to config script
- AC_MSG_CHECKING([for libpng-config])
- if which libpng-config > /dev/null 2>&1; then
+ AC_CHECK_PROG(have_libpng, [libpng-config], [yes (libpng-config)], [no])
+ if test "$have_libpng" != no; then
LIBPNG_CFLAGS=`libpng-config --cflags`
LIBPNG_LIBS=`libpng-config --ldflags`
libpng_libspriv=`libpng-config --static --ldflags`
libpng_libsstaticconf="$libpng_libspriv"
- have_libpng="yes (libpng-config)"
- AC_MSG_RESULT([yes])
- else
- AC_MSG_RESULT([no])
fi
fi
fi