summaryrefslogtreecommitdiff
path: root/Build/source/libs/freetype/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/libs/freetype/Makefile.am')
-rw-r--r--Build/source/libs/freetype/Makefile.am46
1 files changed, 46 insertions, 0 deletions
diff --git a/Build/source/libs/freetype/Makefile.am b/Build/source/libs/freetype/Makefile.am
new file mode 100644
index 00000000000..77991b7afda
--- /dev/null
+++ b/Build/source/libs/freetype/Makefile.am
@@ -0,0 +1,46 @@
+## Proxy Makefile.am to build FreeType for TeX Live.
+##
+## Copyright (C) 2009 Peter Breitenlohner <tex-live@tug.org>
+##
+## This file is free software; the copyright holder
+## gives unlimited permission to copy and/or distribute it,
+## with or without modifications, as long as this notice is preserved.
+##
+ACLOCAL_AMFLAGS = -I ../../m4
+
+## We want to re-distribute the whole original FreeType source tree.
+##
+## With current automake (1.10.2) 'make distcheck' fails when
+## DISTFILES contains a directory and files in that directory.
+EXTRA_DIST = $(FREETYPE_TREE)
+
+if build
+
+noinst_DATA = libttf.a
+
+endif build
+
+ft-build/Makefile:
+ rm -rf ft-build
+ $(mkdir_p) ft-build
+ cd ft-build && \
+ $(abs_srcdir)/$(FREETYPE_TREE)/configure \
+ $(config_args) --disable-shared --disable-nls \
+ --prefix=$(abs_builddir)/ft-install \
+ --includedir=$(abs_builddir)
+
+## Unfortunately the FreeType build system installs the headers after the library;
+## get our dependencies right we wait for a second and then touch the library.
+libttf.a: ft-build/Makefile
+ rm -rf ft-install
+ cd ft-build/lib \
+ && $(MAKE) $(AM_MAKEFLAGS) -f arch/unix/Makefile all \
+ && $(MAKE) $(AM_MAKEFLAGS) -f arch/unix/Makefile install
+ mv ft-install/lib/libttf.a .
+ sleep 1
+ touch libttf.a
+ rm -rf ft-install
+
+clean-local:
+ rm -rf libttf.a freetype ft-build ft-install
+