summaryrefslogtreecommitdiff
path: root/Build/source/libs/curl/packages/Linux
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/libs/curl/packages/Linux')
-rw-r--r--Build/source/libs/curl/packages/Linux/Makefile.am1
-rw-r--r--Build/source/libs/curl/packages/Linux/Makefile.in339
-rw-r--r--Build/source/libs/curl/packages/Linux/RPM/Makefile.am2
-rw-r--r--Build/source/libs/curl/packages/Linux/RPM/Makefile.in227
-rw-r--r--Build/source/libs/curl/packages/Linux/RPM/README5
-rw-r--r--Build/source/libs/curl/packages/Linux/RPM/curl-ssl.spec.in78
-rw-r--r--Build/source/libs/curl/packages/Linux/RPM/curl.spec.in84
-rw-r--r--Build/source/libs/curl/packages/Linux/RPM/make_curl_rpm62
8 files changed, 0 insertions, 798 deletions
diff --git a/Build/source/libs/curl/packages/Linux/Makefile.am b/Build/source/libs/curl/packages/Linux/Makefile.am
deleted file mode 100644
index 5753055799b..00000000000
--- a/Build/source/libs/curl/packages/Linux/Makefile.am
+++ /dev/null
@@ -1 +0,0 @@
-SUBDIRS = RPM
diff --git a/Build/source/libs/curl/packages/Linux/Makefile.in b/Build/source/libs/curl/packages/Linux/Makefile.in
deleted file mode 100644
index a853d99e444..00000000000
--- a/Build/source/libs/curl/packages/Linux/Makefile.in
+++ /dev/null
@@ -1,339 +0,0 @@
-# Makefile.in generated automatically by automake 1.5 from Makefile.am.
-
-# Copyright 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001
-# Free Software Foundation, Inc.
-# This Makefile.in is free software; the Free Software Foundation
-# gives unlimited permission to copy and/or distribute it,
-# with or without modifications, as long as this notice is preserved.
-
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY, to the extent permitted by law; without
-# even the implied warranty of MERCHANTABILITY or FITNESS FOR A
-# PARTICULAR PURPOSE.
-
-@SET_MAKE@
-
-SHELL = @SHELL@
-
-srcdir = @srcdir@
-top_srcdir = @top_srcdir@
-VPATH = @srcdir@
-prefix = @prefix@
-exec_prefix = @exec_prefix@
-
-bindir = @bindir@
-sbindir = @sbindir@
-libexecdir = @libexecdir@
-datadir = @datadir@
-sysconfdir = @sysconfdir@
-sharedstatedir = @sharedstatedir@
-localstatedir = @localstatedir@
-libdir = @libdir@
-infodir = @infodir@
-mandir = @mandir@
-includedir = @includedir@
-oldincludedir = /usr/include
-pkgdatadir = $(datadir)/@PACKAGE@
-pkglibdir = $(libdir)/@PACKAGE@
-pkgincludedir = $(includedir)/@PACKAGE@
-top_builddir = ../..
-
-ACLOCAL = @ACLOCAL@
-AUTOCONF = @AUTOCONF@
-AUTOMAKE = @AUTOMAKE@
-AUTOHEADER = @AUTOHEADER@
-
-INSTALL = @INSTALL@
-INSTALL_PROGRAM = @INSTALL_PROGRAM@
-INSTALL_DATA = @INSTALL_DATA@
-INSTALL_SCRIPT = @INSTALL_SCRIPT@
-INSTALL_HEADER = $(INSTALL_DATA)
-transform = @program_transform_name@
-NORMAL_INSTALL = :
-PRE_INSTALL = :
-POST_INSTALL = :
-NORMAL_UNINSTALL = :
-PRE_UNINSTALL = :
-POST_UNINSTALL = :
-host_alias = @host_alias@
-host_triplet = @host@
-AMTAR = @AMTAR@
-AS = @AS@
-AWK = @AWK@
-CC = @CC@
-DEPDIR = @DEPDIR@
-DLLTOOL = @DLLTOOL@
-ECHO = @ECHO@
-EXEEXT = @EXEEXT@
-INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
-IPV6_ENABLED = @IPV6_ENABLED@
-KRB4_ENABLED = @KRB4_ENABLED@
-LIBTOOL = @LIBTOOL@
-LN_S = @LN_S@
-NROFF = @NROFF@
-OBJDUMP = @OBJDUMP@
-OBJEXT = @OBJEXT@
-OPENSSL_ENABLED = @OPENSSL_ENABLED@
-PACKAGE = @PACKAGE@
-PERL = @PERL@
-PKGADD_NAME = @PKGADD_NAME@
-PKGADD_PKG = @PKGADD_PKG@
-PKGADD_VENDOR = @PKGADD_VENDOR@
-RANDOM_FILE = @RANDOM_FILE@
-RANLIB = @RANLIB@
-STRIP = @STRIP@
-VERSION = @VERSION@
-VERSIONNUM = @VERSIONNUM@
-YACC = @YACC@
-am__include = @am__include@
-am__quote = @am__quote@
-install_sh = @install_sh@
-
-SUBDIRS = RPM
-subdir = packages/Linux
-mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
-CONFIG_HEADER = $(top_builddir)/lib/config.h \
- $(top_builddir)/src/config.h \
- $(top_builddir)/tests/server/config.h
-CONFIG_CLEAN_FILES =
-DIST_SOURCES =
-
-RECURSIVE_TARGETS = info-recursive dvi-recursive install-info-recursive \
- uninstall-info-recursive all-recursive install-data-recursive \
- install-exec-recursive installdirs-recursive install-recursive \
- uninstall-recursive check-recursive installcheck-recursive
-DIST_COMMON = Makefile.am Makefile.in
-DIST_SUBDIRS = $(SUBDIRS)
-all: all-recursive
-
-.SUFFIXES:
-
-mostlyclean-libtool:
- -rm -f *.lo
-
-clean-libtool:
- -rm -rf .libs _libs
-
-distclean-libtool:
- -rm -f libtool
-$(srcdir)/Makefile.in: Makefile.am $(top_srcdir)/configure.in $(ACLOCAL_M4)
- cd $(top_srcdir) && \
- $(AUTOMAKE) --gnu packages/Linux/Makefile
-Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
- cd $(top_builddir) && \
- CONFIG_HEADERS= CONFIG_LINKS= \
- CONFIG_FILES=$(subdir)/$@ $(SHELL) ./config.status
-uninstall-info-am:
-
-# This directory's subdirectories are mostly independent; you can cd
-# into them and run `make' without going through this Makefile.
-# To change the values of `make' variables: instead of editing Makefiles,
-# (1) if the variable is set in `config.status', edit `config.status'
-# (which will cause the Makefiles to be regenerated when you run `make');
-# (2) otherwise, pass the desired values on the `make' command line.
-$(RECURSIVE_TARGETS):
- @set fnord $(MAKEFLAGS); amf=$$2; \
- dot_seen=no; \
- target=`echo $@ | sed s/-recursive//`; \
- list='$(SUBDIRS)'; for subdir in $$list; do \
- echo "Making $$target in $$subdir"; \
- if test "$$subdir" = "."; then \
- dot_seen=yes; \
- local_target="$$target-am"; \
- else \
- local_target="$$target"; \
- fi; \
- (cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) $$local_target) \
- || case "$$amf" in *=*) exit 1;; *k*) fail=yes;; *) exit 1;; esac; \
- done; \
- if test "$$dot_seen" = "no"; then \
- $(MAKE) $(AM_MAKEFLAGS) "$$target-am" || exit 1; \
- fi; test -z "$$fail"
-
-mostlyclean-recursive clean-recursive distclean-recursive \
-maintainer-clean-recursive:
- @set fnord $(MAKEFLAGS); amf=$$2; \
- dot_seen=no; \
- case "$@" in \
- distclean-* | maintainer-clean-*) list='$(DIST_SUBDIRS)' ;; \
- *) list='$(SUBDIRS)' ;; \
- esac; \
- rev=''; for subdir in $$list; do \
- if test "$$subdir" = "."; then :; else \
- rev="$$subdir $$rev"; \
- fi; \
- done; \
- rev="$$rev ."; \
- target=`echo $@ | sed s/-recursive//`; \
- for subdir in $$rev; do \
- echo "Making $$target in $$subdir"; \
- if test "$$subdir" = "."; then \
- local_target="$$target-am"; \
- else \
- local_target="$$target"; \
- fi; \
- (cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) $$local_target) \
- || case "$$amf" in *=*) exit 1;; *k*) fail=yes;; *) exit 1;; esac; \
- done && test -z "$$fail"
-tags-recursive:
- list='$(SUBDIRS)'; for subdir in $$list; do \
- test "$$subdir" = . || (cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) tags); \
- done
-
-tags: TAGS
-
-ID: $(HEADERS) $(SOURCES) $(LISP) $(TAGS_FILES)
- list='$(SOURCES) $(HEADERS) $(TAGS_FILES)'; \
- unique=`for i in $$list; do \
- if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
- done | \
- $(AWK) ' { files[$$0] = 1; } \
- END { for (i in files) print i; }'`; \
- mkid -fID $$unique $(LISP)
-
-TAGS: tags-recursive $(HEADERS) $(SOURCES) $(TAGS_DEPENDENCIES) \
- $(TAGS_FILES) $(LISP)
- tags=; \
- here=`pwd`; \
- list='$(SUBDIRS)'; for subdir in $$list; do \
- if test "$$subdir" = .; then :; else \
- test -f $$subdir/TAGS && tags="$$tags -i $$here/$$subdir/TAGS"; \
- fi; \
- done; \
- list='$(SOURCES) $(HEADERS) $(TAGS_FILES)'; \
- unique=`for i in $$list; do \
- if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
- done | \
- $(AWK) ' { files[$$0] = 1; } \
- END { for (i in files) print i; }'`; \
- test -z "$(ETAGS_ARGS)$$unique$(LISP)$$tags" \
- || etags $(ETAGS_ARGS) $$tags $$unique $(LISP)
-
-GTAGS:
- here=`CDPATH=: && cd $(top_builddir) && pwd` \
- && cd $(top_srcdir) \
- && gtags -i $(GTAGS_ARGS) $$here
-
-distclean-tags:
- -rm -f TAGS ID GTAGS GRTAGS GSYMS GPATH
-
-DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
-
-top_distdir = ../..
-distdir = $(top_distdir)/$(PACKAGE)-$(VERSION)
-
-distdir: $(DISTFILES)
- @for file in $(DISTFILES); do \
- if test -f $$file; then d=.; else d=$(srcdir); fi; \
- dir=`echo "$$file" | sed -e 's,/[^/]*$$,,'`; \
- if test "$$dir" != "$$file" && test "$$dir" != "."; then \
- $(mkinstalldirs) "$(distdir)/$$dir"; \
- fi; \
- if test -d $$d/$$file; then \
- cp -pR $$d/$$file $(distdir) \
- || exit 1; \
- else \
- test -f $(distdir)/$$file \
- || cp -p $$d/$$file $(distdir)/$$file \
- || exit 1; \
- fi; \
- done
- for subdir in $(SUBDIRS); do \
- if test "$$subdir" = .; then :; else \
- test -d $(distdir)/$$subdir \
- || mkdir $(distdir)/$$subdir \
- || exit 1; \
- (cd $$subdir && \
- $(MAKE) $(AM_MAKEFLAGS) \
- top_distdir="$(top_distdir)" \
- distdir=../$(distdir)/$$subdir \
- distdir) \
- || exit 1; \
- fi; \
- done
-check-am: all-am
-check: check-recursive
-all-am: Makefile
-installdirs: installdirs-recursive
-installdirs-am:
-
-install: install-recursive
-install-exec: install-exec-recursive
-install-data: install-data-recursive
-uninstall: uninstall-recursive
-
-install-am: all-am
- @$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
-
-installcheck: installcheck-recursive
-install-strip:
- $(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
- `test -z '$(STRIP)' || \
- echo "INSTALL_PROGRAM_ENV=STRIPPROG='$(STRIP)'"` install
-mostlyclean-generic:
-
-clean-generic:
-
-distclean-generic:
- -rm -f Makefile $(CONFIG_CLEAN_FILES) stamp-h stamp-h[0-9]*
-
-maintainer-clean-generic:
- @echo "This command is intended for maintainers to use"
- @echo "it deletes files that may require special tools to rebuild."
-clean: clean-recursive
-
-clean-am: clean-generic clean-libtool mostlyclean-am
-
-distclean: distclean-recursive
-
-distclean-am: clean-am distclean-generic distclean-libtool \
- distclean-tags
-
-dvi: dvi-recursive
-
-dvi-am:
-
-info: info-recursive
-
-info-am:
-
-install-data-am:
-
-install-exec-am:
-
-install-info: install-info-recursive
-
-install-man:
-
-installcheck-am:
-
-maintainer-clean: maintainer-clean-recursive
-
-maintainer-clean-am: distclean-am maintainer-clean-generic
-
-mostlyclean: mostlyclean-recursive
-
-mostlyclean-am: mostlyclean-generic mostlyclean-libtool
-
-uninstall-am: uninstall-info-am
-
-uninstall-info: uninstall-info-recursive
-
-.PHONY: $(RECURSIVE_TARGETS) GTAGS all all-am check check-am clean \
- clean-generic clean-libtool clean-recursive distclean \
- distclean-generic distclean-libtool distclean-recursive \
- distclean-tags distdir dvi dvi-am dvi-recursive info info-am \
- info-recursive install install-am install-data install-data-am \
- install-data-recursive install-exec install-exec-am \
- install-exec-recursive install-info install-info-am \
- install-info-recursive install-man install-recursive \
- install-strip installcheck installcheck-am installdirs \
- installdirs-am installdirs-recursive maintainer-clean \
- maintainer-clean-generic maintainer-clean-recursive mostlyclean \
- mostlyclean-generic mostlyclean-libtool mostlyclean-recursive \
- tags tags-recursive uninstall uninstall-am uninstall-info-am \
- uninstall-info-recursive uninstall-recursive
-
-# Tell versions [3.59,3.63) of GNU make to not export all variables.
-# Otherwise a system limit (for SysV at least) may be exceeded.
-.NOEXPORT:
diff --git a/Build/source/libs/curl/packages/Linux/RPM/Makefile.am b/Build/source/libs/curl/packages/Linux/RPM/Makefile.am
deleted file mode 100644
index 5d46d87c671..00000000000
--- a/Build/source/libs/curl/packages/Linux/RPM/Makefile.am
+++ /dev/null
@@ -1,2 +0,0 @@
-EXTRA_DIST = README curl-ssl.spec.in curl.spec.in make_curl_rpm
-
diff --git a/Build/source/libs/curl/packages/Linux/RPM/Makefile.in b/Build/source/libs/curl/packages/Linux/RPM/Makefile.in
deleted file mode 100644
index f66597fc7d4..00000000000
--- a/Build/source/libs/curl/packages/Linux/RPM/Makefile.in
+++ /dev/null
@@ -1,227 +0,0 @@
-# Makefile.in generated automatically by automake 1.5 from Makefile.am.
-
-# Copyright 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001
-# Free Software Foundation, Inc.
-# This Makefile.in is free software; the Free Software Foundation
-# gives unlimited permission to copy and/or distribute it,
-# with or without modifications, as long as this notice is preserved.
-
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY, to the extent permitted by law; without
-# even the implied warranty of MERCHANTABILITY or FITNESS FOR A
-# PARTICULAR PURPOSE.
-
-@SET_MAKE@
-
-SHELL = @SHELL@
-
-srcdir = @srcdir@
-top_srcdir = @top_srcdir@
-VPATH = @srcdir@
-prefix = @prefix@
-exec_prefix = @exec_prefix@
-
-bindir = @bindir@
-sbindir = @sbindir@
-libexecdir = @libexecdir@
-datadir = @datadir@
-sysconfdir = @sysconfdir@
-sharedstatedir = @sharedstatedir@
-localstatedir = @localstatedir@
-libdir = @libdir@
-infodir = @infodir@
-mandir = @mandir@
-includedir = @includedir@
-oldincludedir = /usr/include
-pkgdatadir = $(datadir)/@PACKAGE@
-pkglibdir = $(libdir)/@PACKAGE@
-pkgincludedir = $(includedir)/@PACKAGE@
-top_builddir = ../../..
-
-ACLOCAL = @ACLOCAL@
-AUTOCONF = @AUTOCONF@
-AUTOMAKE = @AUTOMAKE@
-AUTOHEADER = @AUTOHEADER@
-
-INSTALL = @INSTALL@
-INSTALL_PROGRAM = @INSTALL_PROGRAM@
-INSTALL_DATA = @INSTALL_DATA@
-INSTALL_SCRIPT = @INSTALL_SCRIPT@
-INSTALL_HEADER = $(INSTALL_DATA)
-transform = @program_transform_name@
-NORMAL_INSTALL = :
-PRE_INSTALL = :
-POST_INSTALL = :
-NORMAL_UNINSTALL = :
-PRE_UNINSTALL = :
-POST_UNINSTALL = :
-host_alias = @host_alias@
-host_triplet = @host@
-AMTAR = @AMTAR@
-AS = @AS@
-AWK = @AWK@
-CC = @CC@
-DEPDIR = @DEPDIR@
-DLLTOOL = @DLLTOOL@
-ECHO = @ECHO@
-EXEEXT = @EXEEXT@
-INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
-IPV6_ENABLED = @IPV6_ENABLED@
-KRB4_ENABLED = @KRB4_ENABLED@
-LIBTOOL = @LIBTOOL@
-LN_S = @LN_S@
-NROFF = @NROFF@
-OBJDUMP = @OBJDUMP@
-OBJEXT = @OBJEXT@
-OPENSSL_ENABLED = @OPENSSL_ENABLED@
-PACKAGE = @PACKAGE@
-PERL = @PERL@
-PKGADD_NAME = @PKGADD_NAME@
-PKGADD_PKG = @PKGADD_PKG@
-PKGADD_VENDOR = @PKGADD_VENDOR@
-RANDOM_FILE = @RANDOM_FILE@
-RANLIB = @RANLIB@
-STRIP = @STRIP@
-VERSION = @VERSION@
-VERSIONNUM = @VERSIONNUM@
-YACC = @YACC@
-am__include = @am__include@
-am__quote = @am__quote@
-install_sh = @install_sh@
-
-EXTRA_DIST = README curl-ssl.spec.in curl.spec.in make_curl_rpm
-subdir = packages/Linux/RPM
-mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
-CONFIG_HEADER = $(top_builddir)/lib/config.h \
- $(top_builddir)/src/config.h \
- $(top_builddir)/tests/server/config.h
-CONFIG_CLEAN_FILES = curl.spec curl-ssl.spec
-DIST_SOURCES =
-DIST_COMMON = README Makefile.am Makefile.in curl-ssl.spec.in \
- curl.spec.in
-all: all-am
-
-.SUFFIXES:
-
-mostlyclean-libtool:
- -rm -f *.lo
-
-clean-libtool:
- -rm -rf .libs _libs
-
-distclean-libtool:
- -rm -f libtool
-$(srcdir)/Makefile.in: Makefile.am $(top_srcdir)/configure.in $(ACLOCAL_M4)
- cd $(top_srcdir) && \
- $(AUTOMAKE) --gnu packages/Linux/RPM/Makefile
-Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
- cd $(top_builddir) && \
- CONFIG_HEADERS= CONFIG_LINKS= \
- CONFIG_FILES=$(subdir)/$@ $(SHELL) ./config.status
-curl.spec: $(top_builddir)/config.status curl.spec.in
- cd $(top_builddir) && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= CONFIG_LINKS= $(SHELL) ./config.status
-curl-ssl.spec: $(top_builddir)/config.status curl-ssl.spec.in
- cd $(top_builddir) && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= CONFIG_LINKS= $(SHELL) ./config.status
-uninstall-info-am:
-tags: TAGS
-TAGS:
-
-
-DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
-
-top_distdir = ../../..
-distdir = $(top_distdir)/$(PACKAGE)-$(VERSION)
-
-distdir: $(DISTFILES)
- @for file in $(DISTFILES); do \
- if test -f $$file; then d=.; else d=$(srcdir); fi; \
- dir=`echo "$$file" | sed -e 's,/[^/]*$$,,'`; \
- if test "$$dir" != "$$file" && test "$$dir" != "."; then \
- $(mkinstalldirs) "$(distdir)/$$dir"; \
- fi; \
- if test -d $$d/$$file; then \
- cp -pR $$d/$$file $(distdir) \
- || exit 1; \
- else \
- test -f $(distdir)/$$file \
- || cp -p $$d/$$file $(distdir)/$$file \
- || exit 1; \
- fi; \
- done
-check-am: all-am
-check: check-am
-all-am: Makefile
-
-installdirs:
-
-install: install-am
-install-exec: install-exec-am
-install-data: install-data-am
-uninstall: uninstall-am
-
-install-am: all-am
- @$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
-
-installcheck: installcheck-am
-install-strip:
- $(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
- `test -z '$(STRIP)' || \
- echo "INSTALL_PROGRAM_ENV=STRIPPROG='$(STRIP)'"` install
-mostlyclean-generic:
-
-clean-generic:
-
-distclean-generic:
- -rm -f Makefile $(CONFIG_CLEAN_FILES) stamp-h stamp-h[0-9]*
-
-maintainer-clean-generic:
- @echo "This command is intended for maintainers to use"
- @echo "it deletes files that may require special tools to rebuild."
-clean: clean-am
-
-clean-am: clean-generic clean-libtool mostlyclean-am
-
-distclean: distclean-am
-
-distclean-am: clean-am distclean-generic distclean-libtool
-
-dvi: dvi-am
-
-dvi-am:
-
-info: info-am
-
-info-am:
-
-install-data-am:
-
-install-exec-am:
-
-install-info: install-info-am
-
-install-man:
-
-installcheck-am:
-
-maintainer-clean: maintainer-clean-am
-
-maintainer-clean-am: distclean-am maintainer-clean-generic
-
-mostlyclean: mostlyclean-am
-
-mostlyclean-am: mostlyclean-generic mostlyclean-libtool
-
-uninstall-am: uninstall-info-am
-
-.PHONY: all all-am check check-am clean clean-generic clean-libtool \
- distclean distclean-generic distclean-libtool distdir dvi \
- dvi-am info info-am install install-am install-data \
- install-data-am install-exec install-exec-am install-info \
- install-info-am install-man install-strip installcheck \
- installcheck-am installdirs maintainer-clean \
- maintainer-clean-generic mostlyclean mostlyclean-generic \
- mostlyclean-libtool uninstall uninstall-am uninstall-info-am
-
-# Tell versions [3.59,3.63) of GNU make to not export all variables.
-# Otherwise a system limit (for SysV at least) may be exceeded.
-.NOEXPORT:
diff --git a/Build/source/libs/curl/packages/Linux/RPM/README b/Build/source/libs/curl/packages/Linux/RPM/README
deleted file mode 100644
index a48ece0433d..00000000000
--- a/Build/source/libs/curl/packages/Linux/RPM/README
+++ /dev/null
@@ -1,5 +0,0 @@
-Author: Daniel (I'm not trustworthy, replace this!)
-
-Paul Marquis's 'make_curl_rpm' script is a fine example on how to automate the
-jobs. You need to fill in your own name and email at least.
-
diff --git a/Build/source/libs/curl/packages/Linux/RPM/curl-ssl.spec.in b/Build/source/libs/curl/packages/Linux/RPM/curl-ssl.spec.in
deleted file mode 100644
index 15713bed80f..00000000000
--- a/Build/source/libs/curl/packages/Linux/RPM/curl-ssl.spec.in
+++ /dev/null
@@ -1,78 +0,0 @@
-%define name curl-ssl
-%define tarball curl
-%define version @VERSION@
-%define release 1
-%define prefix /usr
-
-%define builddir $RPM_BUILD_DIR/%{tarball}-%{version}
-
-Summary: get a file from a FTP, GOPHER or HTTP server.
-Name: %{name}
-Version: %{version}
-Release: %{release}
-Copyright: MPL
-Vendor: Daniel Stenberg <Daniel.Stenberg@haxx.se>
-Packager: Loic Dachary <loic@senga.org>
-Group: Utilities/Console
-Source: %{tarball}-%{version}.tar.gz
-URL: http://curl.haxx.se/
-BuildRoot: /tmp/%{tarball}-%{version}-root
-Requires: openssl >= 0.9.5
-
-%description
-curl is a client to get documents/files from servers, using any of the
-supported protocols. The command is designed to work without user
-interaction or any kind of interactivity.
-
-curl offers a busload of useful tricks like proxy support, user
-authentication, ftp upload, HTTP post, file transfer resume and more.
-
-%package devel
-Summary: The includes, libs, and man pages to develop with libcurl
-Group: Development/Libraries
-Requires: openssl-devel >= 0.9.5
-
-%description devel
-libcurl is the core engine of curl; this packages contains all the libs,
-headers, and manual pages to develop applications using libcurl.
-
-%prep
-rm -rf %{builddir}
-
-%setup -n %{tarball}-%{version}
-
-%build
-%configure --prefix=%{prefix} --with-ssl
-make
-
-%install
-rm -rf $RPM_BUILD_ROOT
-make DESTDIR=$RPM_BUILD_ROOT install-strip
-
-%clean
-rm -rf $RPM_BUILD_ROOT
-rm -rf %{builddir}
-
-%post
-/sbin/ldconfig
-
-%postun
-/sbin/ldconfig
-
-%files
-%defattr(-,root,root)
-%attr(0755,root,root) %{_bindir}/curl
-%attr(0644,root,root) %{_mandir}/man1/*
-%{_libdir}/libcurl.so*
-%doc CHANGES LEGAL MITX.txt MPL-1.1.txt README docs/BUGS
-%doc docs/CONTRIBUTE docs/FAQ docs/FEATURES docs/INSTALL docs/INTERNALS
-%doc docs/LIBCURL docs/MANUAL docs/README* docs/RESOURCES docs/TODO
-%doc docs/TheArtOfHttpScripting
-
-%files devel
-%defattr(-,root,root)
-%attr(0644,root,root) %{_mandir}/man3/*
-%attr(0644,root,root) %{_includedir}/curl/*
-%{_libdir}/libcurl.a
-%{_libdir}/libcurl.la
-%doc docs/examples/*
diff --git a/Build/source/libs/curl/packages/Linux/RPM/curl.spec.in b/Build/source/libs/curl/packages/Linux/RPM/curl.spec.in
deleted file mode 100644
index a5e8d2dd7a0..00000000000
--- a/Build/source/libs/curl/packages/Linux/RPM/curl.spec.in
+++ /dev/null
@@ -1,84 +0,0 @@
-%define name curl
-%define version @VERSION@
-%define release 1
-%define prefix /usr
-
-%define builddir $RPM_BUILD_DIR/%{name}-%{version}
-
-Summary: get a file from a FTP, GOPHER or HTTP server.
-Name: %{name}
-Version: %{version}
-Release: %{release}
-Copyright: MPL
-Vendor: Daniel Stenberg <Daniel.Stenberg@haxx.se>
-Packager: Loic Dachary <loic@senga.org>
-Group: Utilities/Console
-Source: %{name}-%{version}.tar.gz
-URL: http://curl.haxx.se/
-BuildRoot: /tmp/%{name}-%{version}-root
-
-%description
-curl is a client to get documents/files from servers, using any of the
-supported protocols. The command is designed to work without user
-interaction or any kind of interactivity.
-
-curl offers a busload of useful tricks like proxy support, user
-authentication, ftp upload, HTTP post, file transfer resume and more.
-
-Note: this version is compiled without SSL (https:) support.
-
-%package devel
-Summary: The includes, libs, and man pages to develop with libcurl
-Group: Development/Libraries
-
-%description devel
-libcurl is the core engine of curl; this packages contains all the libs,
-headers, and manual pages to develop applications using libcurl.
-
-%prep
-rm -rf %{builddir}
-
-%setup
-
-%build
-%configure --without-ssl --prefix=%{prefix}
-make
-
-%install
-rm -rf $RPM_BUILD_ROOT
-make DESTDIR=$RPM_BUILD_ROOT install-strip
-
-%clean
-rm -rf $RPM_BUILD_ROOT
-rm -rf %{builddir}
-
-%post
-/sbin/ldconfig
-
-%postun
-/sbin/ldconfig
-
-%files
-%defattr(-,root,root)
-%attr(0755,root,root) %{_bindir}/curl
-%attr(0644,root,root) %{_mandir}/man1/*
-%{prefix}/lib/libcurl.so*
-%doc CHANGES LEGAL MITX.txt MPL-1.1.txt README docs/BUGS
-%doc docs/CONTRIBUTE docs/FAQ docs/FEATURES docs/INSTALL docs/INTERNALS
-%doc docs/LIBCURL docs/MANUAL docs/README* docs/RESOURCES docs/TODO
-%doc docs/TheArtOfHttpScripting
-
-%files devel
-%defattr(-,root,root)
-%attr(0644,root,root) %{_mandir}/man3/*
-%attr(0644,root,root) %{_includedir}/curl/*
-%{prefix}/lib/libcurl.a
-%{prefix}/lib/libcurl.la
-%doc docs/examples/*
-
-%changelog
-* Sun Jan 7 2001 Loic Dachary <loic@senga.org>
-
- - use _mandir instead of prefix to locate man pages because
- _mandir is not always prefix/man/man?.
-
diff --git a/Build/source/libs/curl/packages/Linux/RPM/make_curl_rpm b/Build/source/libs/curl/packages/Linux/RPM/make_curl_rpm
deleted file mode 100644
index 544a23b67fc..00000000000
--- a/Build/source/libs/curl/packages/Linux/RPM/make_curl_rpm
+++ /dev/null
@@ -1,62 +0,0 @@
-#! /bin/sh
-# script to build curl RPM from src RPM (SSL and non-SSL versions)
-
-# initialize
-top_dir=/usr/src/redhat
-sources_dir=$top_dir/SOURCES
-specs_dir=$top_dir/SPECS
-rpms_dir=$top_dir/RPMS
-arch=`rpm --showrc | awk 'NF == 3 && $2 == "_arch" { print $3 }'`
-
-# fill in your own name and email here
-packager_name="Mr Joe Packager Person"
-packager_email='<Joe@packager.person>'
-
-# make sure we're running as root
-if test `id -u` -ne `id -u root`
-then
- echo "you must build the RPM as root"
- exit 1
-fi
-
-# get version and release number
-if test $# -lt 1
-then
- echo "version number?"
- read version
-else
- version=$1
-fi
-
-if test $# -lt 2
-then
- echo "release number?"
- read release
-else
- release=$2
-fi
-
-# build all the files
-targets="curl curl-ssl"
-for target in $targets
-do
- # make sure src RPM exist
- src_rpm="$target-$version-$release.src.rpm"
- if test -f $src_rpm
- then
- rpm -ivh $src_rpm
-
- # replace packager in spec file
- sed -e 's/^Packager: .*/Packager: $packager_name $packager_email/' $specs_dir/$target.spec > $specs_dir/$target-$version-$arch.spec
-
- # build it
- if ! rpm -ba $specs_dir/$target-$version-$arch.spec
- then
- echo "error building $target for $arch -- check output above"
- fi
-
- echo "$target rpm is now in $rpms_dir/$arch"
- else
- echo $src_rpm does not exist
- fi
-done