summaryrefslogtreecommitdiff
path: root/Build/source/libs/curl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/libs/curl/Makefile.am')
-rw-r--r--Build/source/libs/curl/Makefile.am73
1 files changed, 73 insertions, 0 deletions
diff --git a/Build/source/libs/curl/Makefile.am b/Build/source/libs/curl/Makefile.am
new file mode 100644
index 00000000000..a7c6097b397
--- /dev/null
+++ b/Build/source/libs/curl/Makefile.am
@@ -0,0 +1,73 @@
+#
+# $Id: Makefile.am,v 1.31 2002/03/04 10:15:12 bagder Exp $
+#
+
+AUTOMAKE_OPTIONS = foreign
+
+EXTRA_DIST = \
+ CHANGES LEGAL maketgz MITX.txt MPL-1.1.txt \
+ reconf Makefile.dist curl-config.in build_vms.com curl-mode.el
+
+bin_SCRIPTS = curl-config
+
+SUBDIRS = docs lib src include tests packages
+
+# create a root makefile in the distribution:
+dist-hook:
+ cp $(srcdir)/Makefile.dist $(distdir)/Makefile
+
+html:
+ cd docs; make html
+
+check: test
+
+test:
+ @(cd tests; $(MAKE) quiet-test)
+
+#
+# Build source and binary rpms. For rpm-3.0 and above, the ~/.rpmmacros
+# must contain the following line:
+# %_topdir /home/loic/local/rpm
+# and that /home/loic/local/rpm contains the directory SOURCES, BUILD etc.
+#
+# cd /home/loic/local/rpm ; mkdir -p SOURCES BUILD RPMS/i386 SPECS SRPMS
+#
+# If additional configure flags are needed to build the package, add the
+# following in ~/.rpmmacros
+# %configure CFLAGS="%{optflags}" ./configure %{_target_platform} --prefix=%{_prefix} ${AM_CONFIGFLAGS}
+# and run make rpm in the following way:
+# AM_CONFIGFLAGS='--with-uri=/home/users/loic/local/RedHat-6.2' make rpm
+#
+
+rpms:
+ $(MAKE) RPMDIST=curl rpm
+ $(MAKE) RPMDIST=curl-ssl rpm
+
+rpm:
+ RPM_TOPDIR=`rpm --showrc | $(PERL) -n -e 'print if(s/.*_topdir\s+(.*)/$$1/)'` ; \
+ cp $(srcdir)/packages/Linux/RPM/$(RPMDIST).spec $$RPM_TOPDIR/SPECS ; \
+ cp $(PACKAGE)-$(VERSION).tar.gz $$RPM_TOPDIR/SOURCES ; \
+ rpm -ba --clean --rmsource $$RPM_TOPDIR/SPECS/$(RPMDIST).spec ; \
+ mv $$RPM_TOPDIR/RPMS/i386/$(RPMDIST)-*.rpm . ; \
+ mv $$RPM_TOPDIR/SRPMS/$(RPMDIST)-*.src.rpm .
+
+#
+# Build a Solaris pkkgadd format file
+# run 'make pkgadd' once you've done './configure' and 'make' to make a Solaris pkgadd format
+# file (which ends up back in this directory).
+# The pkgadd file is in 'pkgtrans' format, so to install on Solaris, do
+# pkgadd -d ./HAXXcurl-*
+#
+
+# gak - libtool requires an absoulte directory, hence the pwd below...
+pkgadd:
+ umask 022 ; \
+ make install DESTDIR=`/bin/pwd`/packages/Solaris/root ; \
+ cat LEGAL MITX.txt MPL-1.1.txt > $(srcdir)/packages/Solaris/copyright ; \
+ cd $(srcdir)/packages/Solaris && $(MAKE) package
+
+#
+# Build a cygwin binary tarball installation file
+# resulting .tar.bz2 file will end up at packages/Win32/cygwin
+cygwinbin:
+ $(MAKE) -C packages/Win32/cygwin cygwinbin