summaryrefslogtreecommitdiff
path: root/Build/source/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/doc/Makefile.am')
-rw-r--r--Build/source/doc/Makefile.am32
1 files changed, 21 insertions, 11 deletions
diff --git a/Build/source/doc/Makefile.am b/Build/source/doc/Makefile.am
index 23aa01a0218..a9caaf8b59b 100644
--- a/Build/source/doc/Makefile.am
+++ b/Build/source/doc/Makefile.am
@@ -34,35 +34,45 @@ readme-install: readme-files
# none of this is intended to be executed except manually.
mydoc = tlbuild
-# until the next texinfo release, need development texinfo
-# for --appendix-sections.
-texinfo_dir = $(HOME)/gnu/src/texinfo
-pod2texi = perl $(texinfo_dir)/Pod-Simple-Texinfo/pod2texi.pl
+# Needs to be the pod2texi from at least Texinfo 6.3.
+pod2texi = pod2texi
pod2texi_args = \
--appendix-sections \
--base-level=section \
--no-fill-section-gaps \
--preamble=''
-# We use a complicated L<> section reference in the tlmgr pod,
-# schematically like this:
+# We use complicated section names in the tlmgr pod, and consequently
+# complicated section references, schematically like this:
# L<whatever|/mysec I<myital>>
# Unfortunately, the Pod module does not pass the necessary information
# in the callbacks to allow pod2texi to preserve the I<>. It seems
# better to kludge in some substitutions here than reimplement a whole
# pod parser. Sigh.
#
-update_node_bad = ref{tlmgr update [option]... [pkg]...
-update_node_good = ref{tlmgr update [\@emph{option}]... [\@emph{pkg}]...
-install_node_bad = ref{tlmgr install [option]... pkg...
-install_node_good = ref{tlmgr install [\@emph{option}]... \@emph{pkg}...
+# The \@... in the replacements are escaping the @ in a Perl
+# double-quote context, i.e., not an array.
+#
+update_node_bad = ref{tlmgr update [option]... [pkg]...,
+update_node_bad2 = ref{tlmgr update,
+update_node_good = ref{tlmgr update [\@emph{option}]... [\@emph{pkg}]...,
+#
+restore_node_bad = ref{tlmgr restore,
+restore_node_good = ref{tlmgr restore [--backupdir \@emph{dir}] [--all | \@emph{pkg} [\@emph{rev}]],
+#
+install_node_bad = ref{tlmgr install [option]... pkg...,
+install_node_good = ref{tlmgr install [\@emph{option}]... \@emph{pkg}...,
# we don't actually use the (autogenerated) -incl.texi file,
-# but it makes for a convenient target.
+# but it makes for a convenient target. Copy the scripts into the build dir.
$(mydoc)-incl.texi: install-tl tlmgr.pl
$(pod2texi) -o $@ --subdir=$(mydoc)-incl $(pod2texi_args) $^
+ cp $(mydoc)-incl/tlmgr.texi $(mydoc)-incl/tlmgr.texi.orig
perl -pi \
-e 's/\Q$(update_node_bad)\E/$(update_node_good)/' \
+ -e ';s/\Q$(update_node_bad2)\E/$(update_node_good),/' \
+ -e ';' \
+ -e 's/\Q$(restore_node_bad)\E/$(restore_node_good)/' \
-e ';' \
-e 's/\Q$(install_node_bad)\E/$(install_node_good)/' \
$(mydoc)-incl/tlmgr.texi