summaryrefslogtreecommitdiff
path: root/Build/source/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/Makefile.am')
-rw-r--r--Build/source/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/Build/source/Makefile.am b/Build/source/Makefile.am
index 729fc8beb68..7db6b6b5136 100644
--- a/Build/source/Makefile.am
+++ b/Build/source/Makefile.am
@@ -53,8 +53,11 @@ world: all
@echo "top-level make $@: running install-strip..."
$(MAKE) $(AM_MAKEFLAGS) install-strip
#
- @echo "top-level make $@: making run-texlinks in $(texlinks_dir) ..."
- cd $(texlinks_dir) && $(MAKE) $(AM_MAKEFLAGS) run-texlinks
+# Just in case it's not a full checkout.
+ if test -d "$(texlinks_dir)"; then \
+ echo "top-level make $@: making run-texlinks in $(texlinks_dir) ..."; \
+ cd $(texlinks_dir) && $(MAKE) $(AM_MAKEFLAGS) run-texlinks; \
+ else :; fi
#
@echo "top-level make $@: running $(check_target)..."
$(MAKE) $(AM_MAKEFLAGS) $(check_target)