summaryrefslogtreecommitdiff
path: root/Build/source/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/Makefile.am')
-rw-r--r--Build/source/Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/Build/source/Makefile.am b/Build/source/Makefile.am
index ef6b765309c..30788889c7f 100644
--- a/Build/source/Makefile.am
+++ b/Build/source/Makefile.am
@@ -9,6 +9,9 @@ ACLOCAL_AMFLAGS = -I m4 --force
## speed up distcheck
DISTCHECK_CONFIGURE_FLAGS = -C
+## check as well for symlinks
+distuninstallcheck_listfiles = find . -type f -o -type l -print
+distcleancheck_listfiles = find . -type f -o -type l -print
EXTRA_DIST = \
Build \
@@ -26,15 +29,15 @@ dist-hook:
rm -rf `find $(distdir) -name .svn`
if build_kpathsea
-SUBDIRS = texk/kpathsea
+SUBDIRS = texk/kpathsea libs utils texk
else !build_kpathsea
-SUBDIRS =
+SUBDIRS = libs utils texk
endif !build_kpathsea
-SUBDIRS += libs utils texk
+DIST_SUBDIRS = auxdir/auxsub texk/kpathsea libs utils texk
# This is the default target for the Build script in TeX Live.
.PHONY: world
-# Run texlinks here since the binaries won't be there
+# Run texlinks here since the binaries won't be there
# at install-data, and fmtutil.cnf won't be there at install-exec,
# and there is no install-hook or install-local.
world: all