summaryrefslogtreecommitdiff
path: root/Build/source/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/Makefile.am')
-rw-r--r--Build/source/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/Build/source/Makefile.am b/Build/source/Makefile.am
index 61e2594ae2c..bdb2dddc7d2 100644
--- a/Build/source/Makefile.am
+++ b/Build/source/Makefile.am
@@ -32,11 +32,14 @@ endif !build_kpathsea
SUBDIRS += libs utils texk
# This is the default target for the Build script in TeX Live.
-#
-# run texlinks here since the binaries won't be there
+.PHONY: world
+# Run texlinks here since the binaries won't be there
# at install-data, and fmtutil.cnf won't be there at install-exec,
# and there is no install-hook or install-local.
-world: all install-strip
+world: all
+## Serialize 'make all' and 'make install-strip'.
+ $(MAKE) $(AM_MAKEFLAGS) install-strip
+##
echo "top-level make $@: running texlinks ..."
cd texk/tetex && $(MAKE) $(AM_MAKEFLAGS) run-texlinks
##