summaryrefslogtreecommitdiff
path: root/Build/source/utils/xpdfopen/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2014-06-18 12:10:20 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2014-06-18 12:10:20 +0000
commit3e2864914687b1af9d1ce374ee11b3a799e9561a (patch)
tree8e6911bfef46a6843e977fda8d837bf6425c7481 /Build/source/utils/xpdfopen/Makefile.am
parent1c0abb83d537ef1e3b95ebd92c646a5d70793d93 (diff)
xpdfopen 0.86
git-svn-id: svn://tug.org/texlive/trunk@34291 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/utils/xpdfopen/Makefile.am')
-rw-r--r--Build/source/utils/xpdfopen/Makefile.am28
1 files changed, 20 insertions, 8 deletions
diff --git a/Build/source/utils/xpdfopen/Makefile.am b/Build/source/utils/xpdfopen/Makefile.am
index 56c8350f6e7..676bdcd3556 100644
--- a/Build/source/utils/xpdfopen/Makefile.am
+++ b/Build/source/utils/xpdfopen/Makefile.am
@@ -3,7 +3,15 @@
## Copyright (C) 2009-2014 Peter Breitenlohner <tex-live@tug.org>
## You may freely use, modify and/or distribute this file.
##
-ACLOCAL_AMFLAGS = -I ../../m4
+EXTRA_DIST = $(XPDFOPEN_TREE)
+
+## Changes applied to the original source tree
+##
+EXTRA_DIST += $(XPDFOPEN_TREE)-PATCHES
+
+# in case of an SVN repository
+dist-hook:
+ rm -rf `find $(distdir) -name .svn -o -name .deps -o -name .dirstamp -o -name '*.$(OBJEXT)'`
AM_CPPFLAGS = $(X_CFLAGS)
AM_CFLAGS = $(WARNING_CFLAGS)
@@ -12,13 +20,19 @@ LDADD = $(X_LIBS) -lX11 -lXmu $(X_EXTRA_LIBS)
bin_PROGRAMS = pdfopen pdfclose
-common_sources = externs.h sendx.c sendx.h utils.c utils.h xpdfopen.h
+common_sources = \
+ @XPDFOPEN_TREE@/sendx.c \
+ @XPDFOPEN_TREE@/utils.c
-pdfopen_SOURCES = pdfopen.c $(common_sources)
+nodist_pdfopen_SOURCES = \
+ @XPDFOPEN_TREE@/pdfopen.c \
+ $(common_sources)
-pdfclose_SOURCES = pdfclose.c $(common_sources)
+nodist_pdfclose_SOURCES = \
+ @XPDFOPEN_TREE@/pdfclose.c \
+ $(common_sources)
-dist_man1_MANS = pdfopen.1
+nodist_man1_MANS = $(XPDFOPEN_TREE)/pdfopen.1
# Symlinks within $(man1dir): FILE:LINK indicates LINK.1->FILE.1
man1_links = pdfopen:pdfclose
@@ -29,7 +43,5 @@ install-data-hook: install-man1-links
uninstall-hook: uninstall-man1-links
-EXTRA_DIST = xpdfopen.pdf xpdfopen.tex
-
-EXTRA_DIST += Makefile.am.orig configure.ac.orig
+EXTRA_DIST += xpdfopen.pdf xpdfopen.tex