summaryrefslogtreecommitdiff
path: root/Build/source/utils/xindy/rte/Makefile.am
diff options
context:
space:
mode:
authorVladimir Volovich <vvv@vsu.ru>2008-04-06 18:53:01 +0000
committerVladimir Volovich <vvv@vsu.ru>2008-04-06 18:53:01 +0000
commit320a8db19049b2f80922143eae02c4150b66a139 (patch)
tree88db35076f3f8fe4521c650c7a29850afcf4c9a1 /Build/source/utils/xindy/rte/Makefile.am
parent70c598ad3062d542d1cf9690e26e4d687d74564e (diff)
configure.ac:
CLISP_LIB can potentially end with a backslash (on mingw), which is treated as a line merging character in Makefile, so add _AM_SUBST_NOTMAKE(CLISP_LIB) to avoid such situation, and instead refer to CLISP_LIB as @CLISP_LIB@ configure.ac, rte/Makefile.am, binaries/Makefile.am: on mingw, lisp.run is called lisp.exe on mingw, we need to use .exe suffix for the backend binary (which is called xindy.run on POSIX systems), so to avoid a clash with the frontend user command "xindy", use the name "xindy-lisp.exe" on mingw which is a counterpart of "xindy.run" on POSIX. binaries/Makefile.am: renamed XINDY_RUN to RUN_XINDY to not clash with the newly introduced XINDY_RUN and LISP_RUN variables added -norc to RUN_XINDY git-svn-id: svn://tug.org/texlive/trunk@7336 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/utils/xindy/rte/Makefile.am')
-rw-r--r--Build/source/utils/xindy/rte/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/Build/source/utils/xindy/rte/Makefile.am b/Build/source/utils/xindy/rte/Makefile.am
index 291efd036bb..9ef7e728f8a 100644
--- a/Build/source/utils/xindy/rte/Makefile.am
+++ b/Build/source/utils/xindy/rte/Makefile.am
@@ -27,15 +27,15 @@ EXTRA_DIST = NEWS README
ORDRULES_FILES = ordrules.c ordrules.h rxsub.c rxsub.h mkind.h debug.h link.sh
binariesdir = ../binaries
-all-local: $(binariesdir)/xindy.run $(binariesdir)/base.mem
+all-local: $(binariesdir)/$(XINDY_RUN) $(binariesdir)/base.mem
-$(binariesdir)/xindy.run $(binariesdir)/base.mem:
+$(binariesdir)/$(XINDY_RUN) $(binariesdir)/base.mem:
rm -rf xindy-build-dir
test -f ordrules/link.sh || for i in $(ORDRULES_FILES); do cp -p $(top_srcdir)/rte/ordrules/$$i ordrules/$$i; done
$(MAKE) -C ordrules ordrulei.c
- env CLISP_LINKKIT="$(CLISP_LIB)/linkkit" \
- sh "$(CLISP_LIB)/clisp-link" add-module-set ordrules "$(CLISP_LIB)/full" xindy-build-dir
- cp xindy-build-dir/lisp.run $(binariesdir)/xindy.run
+ env CLISP_LINKKIT='@CLISP_LIB@/linkkit' \
+ sh '@CLISP_LIB@/clisp-link' add-module-set ordrules '@CLISP_LIB@/full' xindy-build-dir
+ cp xindy-build-dir/$(LISP_RUN) $(binariesdir)/$(XINDY_RUN)
cp xindy-build-dir/lispinit.mem $(binariesdir)/base.mem
clean-local: