summaryrefslogtreecommitdiff
path: root/Build/source/utils/xindy/configure.ac
diff options
context:
space:
mode:
authorVladimir Volovich <vvv@vsu.ru>2008-10-15 03:06:29 +0000
committerVladimir Volovich <vvv@vsu.ru>2008-10-15 03:06:29 +0000
commit94c849776780d57b582ecef8474662553b20bb89 (patch)
treed9518b96c088281959cdd988bd632be014af29ee /Build/source/utils/xindy/configure.ac
parent750c50e41009f43c4849c03ae70448f4c5b61e31 (diff)
added the --with-xindy-recode configure option, to allow using `recode' instead of `iconv'
on systems (such as *BSD) which do not support some character set conversion, e.g. from UTF-8 to ISO-IR-111 git-svn-id: svn://tug.org/texlive/trunk@10981 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/utils/xindy/configure.ac')
-rw-r--r--Build/source/utils/xindy/configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/Build/source/utils/xindy/configure.ac b/Build/source/utils/xindy/configure.ac
index 1bb1321fdfa..da9a2ba11eb 100644
--- a/Build/source/utils/xindy/configure.ac
+++ b/Build/source/utils/xindy/configure.ac
@@ -38,6 +38,17 @@ AC_ARG_ENABLE(make-rules, AS_HELP_STRING([--enable-make-rules],[build and instal
AC_ARG_ENABLE(docs, AS_HELP_STRING([--enable-docs],[build and install documentation (default is YES)]))
AC_ARG_ENABLE(tetex-build, AS_HELP_STRING([--enable-tetex-build],[Build as part of a TeX Live installation]))
AC_ARG_WITH(clisp, AS_HELP_STRING([--with-clisp=...],[Use the specified location of the clisp executable (default is search in PATH)]))
+AC_ARG_WITH(xindy-recode, AS_HELP_STRING([--with-xindy-recode],[Use `recode' instead of `iconv' (default is NO)]))
+
+if test "x$with_xindy_recode" = xno; then
+ CONVERT_FROM_UTF8="iconv -f UTF-8 -t "
+else
+ AC_CHECK_PROG(CONVERT_FROM_UTF8, recode, [recode UTF-8..])
+ if test "x$CONVERT_FROM_UTF8" != "xrecode UTF-8.."; then
+ AC_MSG_ERROR([--with-xindy-recode specified, but `recode' not found])
+ fi
+fi
+AC_SUBST(CONVERT_FROM_UTF8)
if test "x$enable_tetex_build" = xyes -a "x$datadir" = "x$prefix"; then
AC_MSG_NOTICE([Using installation layout for TeX Live])