summaryrefslogtreecommitdiff
path: root/Build/source/utils/xindy/configure.ac
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2009-05-08 13:08:15 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2009-05-08 13:08:15 +0000
commitab366acfe8bae5433f1370910f352db9b861a648 (patch)
tree0cd2f44203ce694edaab0b1476e207a33f8ecd8c /Build/source/utils/xindy/configure.ac
parent3bdd1404ffe5d2be044d80526e6224b8e057674e (diff)
new build system: utils/t1utils/ and utils/xindy/
git-svn-id: svn://tug.org/texlive/trunk@13005 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/utils/xindy/configure.ac')
-rw-r--r--Build/source/utils/xindy/configure.ac33
1 files changed, 18 insertions, 15 deletions
diff --git a/Build/source/utils/xindy/configure.ac b/Build/source/utils/xindy/configure.ac
index da9a2ba11eb..fb658d5dd3e 100644
--- a/Build/source/utils/xindy/configure.ac
+++ b/Build/source/utils/xindy/configure.ac
@@ -36,11 +36,13 @@ AC_PROG_MAKE_SET
AC_ARG_ENABLE(make-rules, AS_HELP_STRING([--enable-make-rules],[build and install make-rules package (default is YES)]))
AC_ARG_ENABLE(docs, AS_HELP_STRING([--enable-docs],[build and install documentation (default is YES)]))
-AC_ARG_ENABLE(tetex-build, AS_HELP_STRING([--enable-tetex-build],[Build as part of a TeX Live installation]))
+# This option haqs been renamed --enable-native-texlive-build
+# but should only inherited and not specified here
+# AC_ARG_ENABLE(tetex-build, AS_HELP_STRING([--enable-tetex-build],[Build as part of a TeX Live installation]))
AC_ARG_WITH(clisp, AS_HELP_STRING([--with-clisp=...],[Use the specified location of the clisp executable (default is search in PATH)]))
AC_ARG_WITH(xindy-recode, AS_HELP_STRING([--with-xindy-recode],[Use `recode' instead of `iconv' (default is NO)]))
-if test "x$with_xindy_recode" = xno; then
+if test "x$with_xindy_recode" != xyes; then
CONVERT_FROM_UTF8="iconv -f UTF-8 -t "
else
AC_CHECK_PROG(CONVERT_FROM_UTF8, recode, [recode UTF-8..])
@@ -50,7 +52,8 @@ else
fi
AC_SUBST(CONVERT_FROM_UTF8)
-if test "x$enable_tetex_build" = xyes -a "x$datadir" = "x$prefix"; then
+## if test "x$enable_native_texlive_build" = xyes -a "x$datadir" = "x$prefix"; then
+if test "x$enable_native_texlive_build" = xyes; then
AC_MSG_NOTICE([Using installation layout for TeX Live])
datadir="$prefix/texmf"
docdir="$prefix/texmf/doc/$PACKAGE_NAME"
@@ -59,14 +62,14 @@ if test "x$enable_tetex_build" = xyes -a "x$datadir" = "x$prefix"; then
AC_MSG_NOTICE([Disabling docs building])
enable_docs=no;
fi
- if test -z "$enable_make_rules"; then
- AC_MSG_NOTICE([Disabling make-rules building])
- enable_make_rules=no;
- fi
+# if test -z "$enable_make_rules"; then
+# AC_MSG_NOTICE([Disabling make-rules building])
+# enable_make_rules=no;
+# fi
else
- enable_tetex_build=no
+ enable_native_texlive_build=no
fi
-AM_CONDITIONAL([TETEX_BUILD],[test "x$enable_tetex_build" = xyes])
+AM_CONDITIONAL([TETEX_BUILD],[test "x$enable_native_texlive_build" = xyes])
if test "x$enable_make_rules" != xno; then
AC_PROG_LATEX
@@ -84,7 +87,7 @@ CLISP=
if test "x$with_clisp" = xyes; then
AC_PATH_PROG(CLISP, clisp)
elif test "x$with_clisp" = xno; then
- AC_MSG_ERROR([--without-clisp specified, but clisp is required])
+ KPSE_MSG_ERROR([xindy], [--without-clisp specified, but clisp is required])
elif test -n "$with_clisp"; then
CLISP="$with_clisp"
else
@@ -92,15 +95,15 @@ else
fi
if test -n "$CLISP"; then
- test -x "$CLISP" || AC_MSG_ERROR([clisp is not executable: $CLISP])
+ test -x "$CLISP" || KPSE_MSG_ERROR([xindy], [clisp is not executable: $CLISP])
AC_MSG_CHECKING([for clisp library directory])
CLISP_LIB=`$CLISP -q -norc -x '(progn (princ *lib-directory*) (values))'`
AC_MSG_RESULT([$CLISP_LIB])
- test -f "$CLISP_LIB/clisp-link" || AC_MSG_ERROR([clisp is not usable: expected file is not found: $CLISP_LIB/clisp-link])
- test -d "$CLISP_LIB/full" || AC_MSG_ERROR([clisp is not usable: expected directory is not found: $CLISP_LIB/full])
- test -d "$CLISP_LIB/linkkit" || AC_MSG_ERROR([clisp is not usable: expected directory is not found: $CLISP_LIB/linkkit])
+ test -f "$CLISP_LIB/clisp-link" || KPSE_MSG_ERROR([xindy], [clisp is not usable: expected file is not found: $CLISP_LIB/clisp-link])
+ test -d "$CLISP_LIB/full" || KPSE_MSG_ERROR([xindy], [clisp is not usable: expected directory is not found: $CLISP_LIB/full])
+ test -d "$CLISP_LIB/linkkit" || KPSE_MSG_ERROR([xindy], [clisp is not usable: expected directory is not found: $CLISP_LIB/linkkit])
else
- AC_MSG_ERROR([clisp is required but not found in PATH.
+ KPSE_MSG_ERROR([xindy], [clisp is required but not found in PATH.
Please install clisp or specify the clisp executable location
via the --with-clisp=... option.])
fi