summaryrefslogtreecommitdiff
path: root/Build/source/texk/xdv2pdf/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2009-03-20 10:15:32 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2009-03-20 10:15:32 +0000
commitd7f8ab6ea1a683492b985013a541ab11e33b9f73 (patch)
treea8b719cba4c45e2e308b53ebbd0ebb313a7cbf36 /Build/source/texk/xdv2pdf/Makefile.am
parent9d502c516fe61658f540e6b98621632b91deb53c (diff)
new build system
git-svn-id: svn://tug.org/texlive/trunk@12458 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/xdv2pdf/Makefile.am')
-rw-r--r--Build/source/texk/xdv2pdf/Makefile.am45
1 files changed, 45 insertions, 0 deletions
diff --git a/Build/source/texk/xdv2pdf/Makefile.am b/Build/source/texk/xdv2pdf/Makefile.am
new file mode 100644
index 00000000000..0f39234077f
--- /dev/null
+++ b/Build/source/texk/xdv2pdf/Makefile.am
@@ -0,0 +1,45 @@
+##
+ACLOCAL_AMFLAGS = -I ../../m4
+
+INCLUDES = $(KPATHSEA_INCLUDES)
+AM_CPPFLAGS =
+
+if build
+bin_PROGRAMS = T1Wrap xdv2pdf
+endif build
+
+T1Wrap_SOURCES = \
+ SimplePSInterpreter.h \
+ SimplePSInterpreter.m \
+ T1Wrap.m
+
+T1Wrap_LDFLAGS = -framework Cocoa
+
+xdv2pdf_SOURCES = \
+ DVIops.h \
+ xdv2pdf.cpp \
+ xdv2pdf_globals.h \
+ xdv2pdf_main.c \
+ xdv_kpse_formats.h \
+ xdv2pdf_specials.cpp
+
+## Included by xdv2pdf.cpp
+EXTRA_xdv2pdf_SOURCES = appleGlyphNames.c
+
+xdv2pdf_LDFLAGS = -framework Carbon -framework QuickTime
+
+xdv2pdf_LDADD = $(KPATHSEA_LIBS)
+
+## Rebuild libkpathsea
+@KPATHSEA_RULE@
+
+EXTRA_DIST = LICENSE.txt
+
+## Eventually delete these files
+##
+EXTRA_DIST += \
+ Makefile.in.orig \
+ acconfig.h.dist \
+ acconfig.h.in \
+ configure.in.orig
+