summaryrefslogtreecommitdiff
path: root/Build/source/texk/web2c/omegafonts/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2009-11-10 10:27:09 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2009-11-10 10:27:09 +0000
commit5e8e9500102800e68c9e7fcac9e85c1668b71a36 (patch)
tree81d79ac70ffbb127e8063f18c8f55475ca169ee1 /Build/source/texk/web2c/omegafonts/Makefile.am
parente6a9c88ada2f11dd61e4c4e39dff84944bed5787 (diff)
towards TL2010: texk/web2c
git-svn-id: svn://tug.org/texlive/trunk@15964 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/web2c/omegafonts/Makefile.am')
-rw-r--r--Build/source/texk/web2c/omegafonts/Makefile.am31
1 files changed, 13 insertions, 18 deletions
diff --git a/Build/source/texk/web2c/omegafonts/Makefile.am b/Build/source/texk/web2c/omegafonts/Makefile.am
index 2c3455693e9..afe7082d8d2 100644
--- a/Build/source/texk/web2c/omegafonts/Makefile.am
+++ b/Build/source/texk/web2c/omegafonts/Makefile.am
@@ -3,18 +3,14 @@
## Copyright (C) 2009 Peter Breitenlohner <tex-live@tug.org>
## You may freely use, modify and/or distribute this file.
##
-INCLUDES = -I$(top_builddir)/.. -I$(top_srcdir) $(KPATHSEA_INCLUDES)
+INCLUDES = -I$(top_builddir)/.. -I$(top_srcdir) $(KPATHSEA_INCLUDES) -DNOT_WEB2C
AM_CFLAGS = $(WARNING_CFLAGS)
AM_YFLAGS = -d -v
proglib = ../lib/lib.a
-# Automake automatically uses $(proglib)=../lib/lib.a as dependency.
-# This does not work for the configure substitution $(KPATHSEA_LIBS),
-# thus we let $(proglib) artificially depend on $(KPATHSEA_LIBS).
-#
# Rebuild $(proglib)
-$(proglib): $(KPATHSEA_DEPEND) ${top_srcdir}/lib/*.c
+$(proglib): ${top_srcdir}/lib/*.c
cd ../lib && $(MAKE) $(AM_MAKEFLAGS)
## Rebuild libkpathsea
@@ -64,6 +60,7 @@ omfonts_SOURCES = \
print_routines.h
LDADD = $(proglib) $(KPATHSEA_LIBS)
+omfonts_DEPENDENCIES = $(proglib) $(KPATHSEA_DEPEND)
DISTCLEANFILES = pl-parser.output
@@ -77,7 +74,7 @@ install-exec-hook:
rm -f $$f$(EXEEXT) && \
$(LN_S) omfonts$(EXEEXT) $$f$(EXEEXT) || exit 1; \
done
-unistall-hook:
+uninstall-hook:
for f in $(linked_programs); do \
rm -f $(DESTDIR)$(bindir)/$$f$(EXEEXT); \
done
@@ -86,23 +83,21 @@ endif OTANGLE
## Tests
##
-EXTRA_DIST = omfonts.test specialhex.test
-
-## Test data
-##
-EXTRA_DIST += tests/Cherokee.pl tests/OCherokee.ovp tests/specialhex.ovp
-
if OTANGLE
if OMFONTS
TESTS = omfonts.test specialhex.test
endif OMFONTS
endif OTANGLE
+EXTRA_DIST = omfonts.test specialhex.test
+
+## omfonts.test
+EXTRA_DIST += tests/Cherokee.pl tests/OCherokee.ovp
DISTCLEANFILES += tests/Cherokee.tfm tests/OCherokee.ofm \
tests/OCherokee.opl tests/OCherokee.ovf \
- tests/xCherokee.pl tests/xOCherokee.ofm \
- tests/xOCherokee.opl tests/xOCherokee.ovp \
- tests/specialhex.ofm tests/specialhex.opl \
- tests/specialhex.ovf tests/xspecialhex.ofm \
- tests/xspecialhex.opl tests/xspecialhex.ovp
+ tests/xCherokee.* tests/xOCherokee.*
+## specialhex.test
+EXTRA_DIST += tests/specialhex.ovp
+DISTCLEANFILES += tests/specialhex.ofm tests/specialhex.opl \
+ tests/specialhex.ovf tests/xspecialhex.*