summaryrefslogtreecommitdiff
path: root/Build/source/texk/web2c/omegafonts/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2009-03-20 10:47:15 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2009-03-20 10:47:15 +0000
commita770f7dc16dcbd5ea863f597e42c1901253eb1d7 (patch)
tree28c8cf608cd3c114f94254adda67ca951c69fc65 /Build/source/texk/web2c/omegafonts/Makefile.am
parent1adfc7bd79131e1ad0240ee2cc4acbc5925fab99 (diff)
new build system
git-svn-id: svn://tug.org/texlive/trunk@12464 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/web2c/omegafonts/Makefile.am')
-rw-r--r--Build/source/texk/web2c/omegafonts/Makefile.am75
1 files changed, 75 insertions, 0 deletions
diff --git a/Build/source/texk/web2c/omegafonts/Makefile.am b/Build/source/texk/web2c/omegafonts/Makefile.am
new file mode 100644
index 00000000000..52c893763d0
--- /dev/null
+++ b/Build/source/texk/web2c/omegafonts/Makefile.am
@@ -0,0 +1,75 @@
+##
+INCLUDES = -I$(top_builddir)/.. -I$(top_srcdir) $(KPATHSEA_INCLUDES)
+AM_YFLAGS = -d -v
+
+proglib = ../lib/lib.a
+
+## Automake automatically uses $(proglib)=../lib/lib.a as dependency.
+## This does not work for the configure substitution $(KPATHSEA_LIBS),
+## thus we let $(proglib) artificially depend on $(KPATHSEA_LIBS).
+
+## Rebuild $(proglib)
+$(proglib): $(KPATHSEA_DEPEND) ${top_srcdir}/lib/*.c
+ cd ../lib && $(MAKE) $(AM_MAKEFLAGS)
+
+## Rebuild libkpathsea
+@KPATHSEA_RULE@
+
+bin_PROGRAMS = omfonts
+
+omfonts_SOURCES = \
+ char_routines.c \
+ char_routines.h \
+ dimen_routines.c \
+ dimen_routines.h \
+ dvi.h \
+ error_routines.c \
+ error_routines.h \
+ extra_routines.c \
+ extra_routines.h \
+ font_routines.c \
+ font_routines.h \
+ header_routines.c \
+ header_routines.h \
+ ligkern_routines.c \
+ ligkern_routines.h \
+ list_routines.c \
+ list_routines.h \
+ manifests.h \
+ omfonts.c \
+ omfonts.h \
+ out_ofm.c \
+ out_ofm.h \
+ out_routines.c \
+ out_routines.h \
+ param_routines.c \
+ param_routines.h \
+ parse_ofm.c \
+ parse_ofm.h \
+ parser.h \
+ pl-parser.y \
+ pl-lexer.l \
+ print_routines.c \
+ print_routines.h
+
+LDADD = $(LEXLIB) $(proglib) $(KPATHSEA_LIBS)
+
+DISTCLEANFILES = pl-parser.output
+
+linked_programs = ofm2opl opl2ofm ovf2ovp ovp2ovf
+
+install-exec-hook:
+ cd $(DESTDIR)$(bindir) && for f in $(linked_programs); do \
+ rm -f $$f && $(LN_S) omfonts $$f || exit 1; \
+ done
+
+unistall-hook:
+ for f in $(linked_programs); do \
+ rm -f $(DESTDIR)$(bindir)/$$f; \
+ done
+
+## ######
+## Eventually delete these files
+
+EXTRA_DIST = Makefile.in.orig
+