summaryrefslogtreecommitdiff
path: root/Build/source/texk/web2c/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2011-05-31 09:47:04 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2011-05-31 09:47:04 +0000
commit15cca88e2666b7aae4e54112a21cb5c9bc312069 (patch)
tree8b31517b2e92f03da2b949831029cd9439ce7cef /Build/source/texk/web2c/Makefile.am
parent18662309a8be07470a0bc6294a1fddf5ffcb8d72 (diff)
Use the Makefile fragment `bin_links.am' to create symlinks within $(bindir)
For cygwin always create links `foo->bar.exe' and not `foo.exe->bar.exe' git-svn-id: svn://tug.org/texlive/trunk@22701 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/web2c/Makefile.am')
-rw-r--r--Build/source/texk/web2c/Makefile.am23
1 files changed, 5 insertions, 18 deletions
diff --git a/Build/source/texk/web2c/Makefile.am b/Build/source/texk/web2c/Makefile.am
index af2a2844f8a..ecaa3adb4c4 100644
--- a/Build/source/texk/web2c/Makefile.am
+++ b/Build/source/texk/web2c/Makefile.am
@@ -1,6 +1,6 @@
## Makefile.am for the TeX Live subdirectory texk/web2c/
##
-## Copyright (C) 2009 - 2011 Peter Breitenlohner <tex-live@tug.org>
+## Copyright (C) 2009-2011 Peter Breitenlohner <tex-live@tug.org>
## You may freely use, modify and/or distribute this file.
##
ACLOCAL_AMFLAGS = -I ../../m4 -I m4
@@ -208,21 +208,8 @@ include $(srcdir)/synctexdir/am/synctex.am
## libmd5
include $(srcdir)/libmd5/am/md5.am
-# Symlinks within $(bindir): FILE:LINK indicates LINK$(EXEEXT)->FILE$(EXEEXT)
-install-exec-hook: $(install_exe_links)
- @test -z "$(bin_links)" || { \
- cd $(DESTDIR)$(bindir) && \
- for s in $(bin_links); do \
- link=`echo $$s | sed 's,.*:,,'`$(EXEEXT); \
- file=`echo $$s | sed 's,:.*,,'`$(EXEEXT); \
- rm -f $$link; \
- echo "creating link '$$link' -> '$$file'"; \
- $(LN_S) $$file $$link || exit 1; \
- done; }
-uninstall-hook: $(uninstall_exe_links)
- @test -z "$(bin_links)" || \
- for s in $(bin_links); do \
- link=`echo $$s | sed 's,.*:,,'`$(EXEEXT); \
- rm -f $(DESTDIR)$(bindir)/$$link; \
- done
+## Symlinks within $(bindir)
+include $(srcdir)/../am/bin_links.am
+install-exec-hook: install-bin-links $(install_exe_links)
+uninstall-hook: uninstall-bin-links $(uninstall_exe_links)