summaryrefslogtreecommitdiff
path: root/Build/source/texk/ptexenc/Makefile.am
diff options
context:
space:
mode:
authorKarl Berry <karl@freefriends.org>2021-02-25 19:22:25 +0000
committerKarl Berry <karl@freefriends.org>2021-02-25 19:22:25 +0000
commitad547a6b5986815fda458221149728d9d9ab1d87 (patch)
tree16296910eb3eca724371474ea9aea3994dc69614 /Build/source/texk/ptexenc/Makefile.am
parent947b43de3dd21d58ccc2ffadefc4441ea1c2a813 (diff)
restore Build,TODO from r57911
git-svn-id: svn://tug.org/texlive/trunk@57915 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/ptexenc/Makefile.am')
-rw-r--r--Build/source/texk/ptexenc/Makefile.am49
1 files changed, 49 insertions, 0 deletions
diff --git a/Build/source/texk/ptexenc/Makefile.am b/Build/source/texk/ptexenc/Makefile.am
new file mode 100644
index 00000000000..d7be34975cb
--- /dev/null
+++ b/Build/source/texk/ptexenc/Makefile.am
@@ -0,0 +1,49 @@
+## Makefile.am for the TeX Live subdirectory texk/ptexenc/
+##
+## Copyright (C) 2010-2014 Peter Breitenlohner <tex-live@tug.org>
+## You may freely use, modify and/or distribute this file.
+##
+AM_CPPFLAGS = $(KPATHSEA_INCLUDES)
+AM_CFLAGS = $(WARNING_CFLAGS)
+
+lib_LTLIBRARIES = libptexenc.la
+
+libptexenc_la_CPPFLAGS = $(AM_CPPFLAGS) -DMAKE_PTENC_DLL
+
+libptexenc_la_LDFLAGS = -bindir @bindir@ -no-undefined -version-info $(PTEXENC_LT_VERSINFO)
+
+# Note: jisx0208.h is a copy of ../../libs/gd/gd-2.0.35/jisx0208.h.
+#
+libptexenc_la_SOURCES = \
+ jisx0208.h \
+ kanjicnv.c \
+ ptexenc.c \
+ ptexenc/kanjicnv.h \
+ ptexenc/unicode-jp.h \
+ unicode-jp.c \
+ unicode.c
+
+$(libptexenc_la_OBJECTS): $(KPATHSEA_DEPEND)
+
+libptexenc_la_LIBADD = $(KPATHSEA_LIBS)
+
+## Rebuild libkpathsea
+@KPATHSEA_RULE@
+
+nobase_include_HEADERS = \
+ ptexenc/ptexenc.h \
+ ptexenc/unicode.h
+
+pkgconfigdir = ${libdir}/pkgconfig
+
+pkgconfig_DATA = ptexenc.pc
+
+EXTRA_DIST = COPYRIGHT ChangeLog.jp
+
+# Rebuild
+rebuild_prereq =
+rebuild_target = all
+CLEANFILES =
+
+include $(srcdir)/../../am/rebuild.am
+