summaryrefslogtreecommitdiff
path: root/Build/source/texk/psutils/psutils-1.21/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2013-12-03 12:13:36 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2013-12-03 12:13:36 +0000
commit6c95206204a22fa0f39833b36c446fae569c2eb4 (patch)
tree4d3691c9ba9b979b7d04f022d92a20c3507f2791 /Build/source/texk/psutils/psutils-1.21/Makefile.am
parentef888e5b75caca5afa1021d6eb57437019ea8481 (diff)
psutils: Use getopt() from kpathsea and move from utils/ to texk/
git-svn-id: svn://tug.org/texlive/trunk@32305 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/psutils/psutils-1.21/Makefile.am')
-rw-r--r--Build/source/texk/psutils/psutils-1.21/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/Build/source/texk/psutils/psutils-1.21/Makefile.am b/Build/source/texk/psutils/psutils-1.21/Makefile.am
new file mode 100644
index 00000000000..a3d6f727979
--- /dev/null
+++ b/Build/source/texk/psutils/psutils-1.21/Makefile.am
@@ -0,0 +1,42 @@
+# Makefile for PS utilities
+#
+# Copyright (C) Reuben Thomas 2012
+# See LICENSE for license
+
+SUBDIRS = lib
+
+ACLOCAL_AMFLAGS = -I m4
+
+AM_CFLAGS = $(WERROR_CFLAGS) $(WARN_CFLAGS)
+
+noinst_LIBRARIES = libpsutils.a
+libpsutils_a_SOURCES = psutil.c psspec.c
+libpsutils_a_LIBADD = $(LIBPAPER)
+LDADD = libpsutils.a
+
+bin_PROGRAMS = psbook psselect pstops epsffit psnup psresize
+
+bin_SCRIPTS = psjoin extractres
+
+man_MANS = psutils.1 \
+ psbook.1 psselect.1 pstops.1 epsffit.1 psnup.1 psresize.1 \
+ psjoin.1 extractres.1 includeres.1
+
+EXTRA_DIST = m4/gnulib-cache.m4 \
+ psutil.h psspec.h \
+ $(bin_SCRIPTS) \
+ $(man_MANS)
+
+all: includeres
+
+includeres: extractres
+ $(RM) $@ && $(LN_S) extractres $@
+
+install-exec-hook:
+ cd $(DESTDIR)$(bindir); $(RM) includeres; $(LN_S) extractres includeres
+
+uninstall-hook:
+ $(RM) $(DESTDIR)$(bindir)/includeres
+
+clean-local:
+ $(RM) includeres