summaryrefslogtreecommitdiff
path: root/Build/source/texk/kpathsea/Makefile.am
diff options
context:
space:
mode:
authorKarl Berry <karl@freefriends.org>2010-12-24 17:41:08 +0000
committerKarl Berry <karl@freefriends.org>2010-12-24 17:41:08 +0000
commit0aad51642cee2274efe233768de3d2ceb11131af (patch)
treef83bf7e728d55d0c502f518dd2aba43c44ec5572 /Build/source/texk/kpathsea/Makefile.am
parentb3b61b092bd0a6f544929108803875d22397e57a (diff)
(stamp-paths): check for broken grep before generating paths.h.
git-svn-id: svn://tug.org/texlive/trunk@20849 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/kpathsea/Makefile.am')
-rw-r--r--Build/source/texk/kpathsea/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Build/source/texk/kpathsea/Makefile.am b/Build/source/texk/kpathsea/Makefile.am
index c89cb80fbfd..29050d33e5a 100644
--- a/Build/source/texk/kpathsea/Makefile.am
+++ b/Build/source/texk/kpathsea/Makefile.am
@@ -191,6 +191,10 @@ kpseinclude_HEADERS = \
##
paths.h: stamp-paths
stamp-paths: texmf.cnf bsnl.awk
+# ensure grep is not completely broken, e.g., from GREP_OPTIONS.
+ echo a | grep -v b >/dev/null || { echo "*** grep broken, goodbye."; exit 1; }
+#
+# generate paths.h without build machine directories.
echo "/* paths.h: Generated from texmf.cnf. */" >paths.tmp
awk -f $(srcdir)/bsnl.awk $(srcdir)/texmf.cnf \
| sed -e 's/%.*//' -e 's/^[ ]*//' -e 's/[ ]*$$//' \