summaryrefslogtreecommitdiff
path: root/Build/source/texk/dvipng/help/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2009-06-15 15:12:22 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2009-06-15 15:12:22 +0000
commit44686714a168a1117a294067e0d9943947aeeb7d (patch)
tree26437a3f6ca4f5c6848e3135d72fd3f03e7b0745 /Build/source/texk/dvipng/help/Makefile.am
parent273ed9c5b194dca51ed972db8071522d60733284 (diff)
reorganize texk/dvipng
git-svn-id: svn://tug.org/texlive/trunk@13752 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/dvipng/help/Makefile.am')
-rw-r--r--Build/source/texk/dvipng/help/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/Build/source/texk/dvipng/help/Makefile.am b/Build/source/texk/dvipng/help/Makefile.am
new file mode 100644
index 00000000000..f9291eeae98
--- /dev/null
+++ b/Build/source/texk/dvipng/help/Makefile.am
@@ -0,0 +1,26 @@
+## Makefile.am for the TeX Live subdirectory texk/dvipng/help/
+##
+## Copyright (C) 2009 Peter Breitenlohner <tex-live@tug.org>
+## You may freely use, modify and/or distribute this file.
+##
+DVIPNG_HELP = $(top_srcdir)/doc/dvipng.help
+
+all-local: help-stamp $(DVIPNG_HELP)
+
+# If dvipng.help is to be rebuilt, this would fail for a read-only source
+# directory, but rebuilding dvipng.info would equally fail.
+# Do not even try to rebuild dvipng.help if help-stamp is up to date.
+$(DVIPNG_HELP):
+ $(MAKE) $(AM_MAKEFLAGS) help-stamp
+help-stamp: ../dvipng$(EXEEXT)
+ -(cd .. && ./dvipng) | \
+ sed -e's/ (dvipng) / /' -e's,/lt-dvipng ,/dvipng ,' \
+ -e's,^This is .*/dvipng ,This is ./dvipng ,' \
+ -e's,^Usage: .*/dvipng ,Usage: ./dvipng ,' > dvipng.tmp
+ ( test -r $(DVIPNG_HELP) && diff dvipng.tmp $(DVIPNG_HELP) ) \
+ || cp dvipng.tmp $(DVIPNG_HELP)
+ rm -f dvipng.tmp
+ echo timestamp >$@
+
+DISTCLEANFILES = help-stamp
+