summaryrefslogtreecommitdiff
path: root/Build/source/texk/dvipng/configure.ac
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2010-02-03 10:07:19 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2010-02-03 10:07:19 +0000
commitcd0ab8cca8720fb6230858653c52847f7f49a6cb (patch)
tree72fa6ba32b3c571cb9725eebe15859843f05a68a /Build/source/texk/dvipng/configure.ac
parenta097a42d71e755e4b784eb6711c00d754dd1d193 (diff)
build system: minor update
git-svn-id: svn://tug.org/texlive/trunk@16910 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/dvipng/configure.ac')
-rw-r--r--Build/source/texk/dvipng/configure.ac28
1 files changed, 12 insertions, 16 deletions
diff --git a/Build/source/texk/dvipng/configure.ac b/Build/source/texk/dvipng/configure.ac
index afece4cf058..99cbf09632f 100644
--- a/Build/source/texk/dvipng/configure.ac
+++ b/Build/source/texk/dvipng/configure.ac
@@ -96,6 +96,10 @@ KPSE_T1LIB_FLAGS
KPSE_FREETYPE2_FLAGS
KPSE_GD_FLAGS
+# Assume we have t1lib and freetype2.
+have_t1=yes
+have_ft2=yes
+
if test "x$enable_build" != xno || test -f config.force; then
# Checks for more libraries.
@@ -112,16 +116,15 @@ AC_CHECK_FUNC([png_read_image],
KPSE_ADD_FLAGS([t1lib])
AC_CHECK_FUNC([T1_InitLib],
- [have_ft2_or_t1=yes
- AC_DEFINE([HAVE_LIBT1], 1,
+ [AC_DEFINE([HAVE_LIBT1], 1,
[Define to 1 if you have the `t1' library (-lt1).])],
- [have_ft2_or_t1=no])
+ [have_t1=no])
KPSE_ADD_FLAGS([freetype2])
AC_CHECK_FUNC([FT_Init_FreeType],
- [have_ft2_or_t1=yes
- AC_DEFINE([HAVE_FT2], 1,
- [Define to 1 if you have freetype2.])])
+ [AC_DEFINE([HAVE_FT2], 1,
+ [Define to 1 if you have freetype2.])],
+ [have_ft2=no])
KPSE_ADD_FLAGS([gd])
AC_CHECK_FUNC([gdImageCreate],
@@ -154,18 +157,11 @@ KPSE_RESTORE_FLAGS
echo timestamp >config.force
-else
-
-# For TeX Live we always have t1lib and freetype2.
-AM_CONDITIONAL([have_t1], [true])
-AM_CONDITIONAL([have_ft2], [true])
-have_ft2_or_t1=yes
-
fi
-AM_CONDITIONAL([have_t1], [test "x$ac_cv_func_T1_InitLib" = xyes])
-AM_CONDITIONAL([have_ft2], [test "x$ac_cv_func_FT_Init_FreeType" = xyes])
-AM_CONDITIONAL([have_ft2_or_t1], [test "x$have_ft2_or_t1" = xyes])
+AM_CONDITIONAL([have_t1], [test "x$have_t1" = xyes])
+AM_CONDITIONAL([have_ft2], [test "x$have_ft2" = xyes])
+AM_CONDITIONAL([have_ft2_or_t1], [test "x$have_ft2:$have_t1" != xno:no])
AM_CONDITIONAL([have_gif], [test "x$ac_cv_func_gdImageGif" = xyes])
AC_MSG_RESULT([