summaryrefslogtreecommitdiff
path: root/Build/source/texk/cjkutils/configure.in
diff options
context:
space:
mode:
authorKarl Berry <karl@freefriends.org>2006-01-17 21:41:51 +0000
committerKarl Berry <karl@freefriends.org>2006-01-17 21:41:51 +0000
commit487ca4806cc046076293cf6cc5fbba0db282bac7 (patch)
tree847b412ab5158dd7bdd7ed7e5a4cc3fbca94be32 /Build/source/texk/cjkutils/configure.in
parenta3d3111bfe26b8e5f5bc6049dfb2a4ca2edc7881 (diff)
texk 1
git-svn-id: svn://tug.org/texlive/trunk@1485 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/cjkutils/configure.in')
-rw-r--r--Build/source/texk/cjkutils/configure.in57
1 files changed, 57 insertions, 0 deletions
diff --git a/Build/source/texk/cjkutils/configure.in b/Build/source/texk/cjkutils/configure.in
new file mode 100644
index 00000000000..d58f4628474
--- /dev/null
+++ b/Build/source/texk/cjkutils/configure.in
@@ -0,0 +1,57 @@
+dnl Process this file with autoconf to produce a configure script.
+AC_INIT(hbf2gf/hbf.h)
+
+AC_CONFIG_HEADERS([hbf2gf/c-auto.h:hbf2gf/c-auto.in])
+
+dnl check host
+AC_CANONICAL_SYSTEM
+AC_PROG_MAKE_SET
+
+
+dnl Checks for programs.
+AC_PROG_CC
+
+
+dnl Checks for header files.
+AC_HEADER_STDC
+
+
+dnl get Compiler flags right.
+if test "x$CC" = xgcc; then
+ XX_CFLAGS="-Wall"
+else
+ case "$host" in
+ alpha-dec-osf*)
+ XX_CFLAGS="-std1 -O2 -g3"
+ ;;
+ *)
+ XX_CFLAGS=
+ ;;
+ esac
+fi
+AC_SUBST(XX_CFLAGS)
+
+
+dnl Checks for typedefs, structures, and compiler characteristics.
+AC_C_CONST
+AC_STRUCT_TM
+
+
+dnl Checks for library functions.
+AC_FUNC_VPRINTF
+AC_CHECK_FUNCS(strdup strstr strtol strtoul)
+
+dnl we need this for hbf.c
+if test "x$ac_cv_func_strdup" = xno; then
+ no_strdup=-DNO_STRDUP
+fi
+AC_SUBST(no_strdup)
+
+AC_CHECK_PROG(RM, rm, rm)
+AC_PROG_INSTALL
+
+sinclude(../kpathsea/withenable.ac)
+
+KPSE_CONFIG_FILES([Makefile conv/Makefile hbf2gf/Makefile scripts/Makefile])
+AC_OUTPUT
+date >stamp-auto