summaryrefslogtreecommitdiff
path: root/Build/source/texk/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2012-12-29 14:32:45 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2012-12-29 14:32:45 +0000
commit9da2af345bbc3848d181319a77b830c77034ae1e (patch)
tree74832eb1c57486b7ce18e0d987150cbdf42876a9 /Build/source/texk/Makefile.am
parenta7c9a7ff1a6d0925eafe21175304c494e266b319 (diff)
build system: Enable "silent rules" (see Automake manual)
git-svn-id: svn://tug.org/texlive/trunk@28654 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/Makefile.am')
-rw-r--r--Build/source/texk/Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/Build/source/texk/Makefile.am b/Build/source/texk/Makefile.am
index 29d41c58625..3529e918507 100644
--- a/Build/source/texk/Makefile.am
+++ b/Build/source/texk/Makefile.am
@@ -1,6 +1,6 @@
## Makefile.am for the TeX Live subdirectory texk/
##
-## Copyright (C) 2009, 2010 Peter Breitenlohner <tex-live@tug.org>
+## Copyright (C) 2009-2012 Peter Breitenlohner <tex-live@tug.org>
## You may freely use, modify and/or distribute this file.
##
## Use 'aclocal --force' (for "computed m4_sinclude")
@@ -10,6 +10,11 @@ ACLOCAL_AMFLAGS = -I ../m4 --force
SUBDIRS = . $(SUBTEXK)
DIST_SUBDIRS = $(DIST_SUBTEXK)
+cf_silent = $(cf_silent_@AM_V@)
+cf_silent_ = $(cf_silent_@AM_DEFAULT_V@)
+cf_silent_0 = --silent
+cf_silent_1 =
+
# just in case a subdirectory has added directories
dist-hook:
rm -rf `find $(distdir) -name .svn`
@@ -24,7 +29,7 @@ all-local: subtexk
# we append '--disable-build' so they can skip tests that would
# fail because, e.g., some required libraries were not built.
#
-# Sequentially configure and optionally build all texk subdirs;
+# Sequentially configure and optionally build all texk programs;
# code inspired by automake's way to handle recursive targets.
subtexk: $(CONFIG_AUX)
@fail= failcom='exit 1'; \
@@ -43,9 +48,9 @@ subtexk: $(CONFIG_AUX)
*) skip=' --disable-build';; \
esac; \
(cd $$subtexk && echo "=== configuring in $$subtexk (`pwd`)" && \
- echo "make: running $(SHELL) $$cmd$$skip" && \
+ if $(AM_V_P); then echo "make: running $(SHELL) $$cmd$$skip"; fi && \
CONFIG_SHELL=$(SHELL) && export CONFIG_SHELL && \
- eval $(SHELL) $$cmd$$skip || \
+ eval $(SHELL) $$cmd$$skip $(cf_silent) || \
{ echo "=== configuring in $$subtexk failed"; exit 1; }) && \
if test "x$$skip" = x; then \
echo "Making all in $$subtexk" && \