summaryrefslogtreecommitdiff
path: root/Build/source/libs/zlib/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2009-03-20 07:45:16 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2009-03-20 07:45:16 +0000
commit9c241c5d2d9413361d32567876c35b2b9e2754c9 (patch)
tree754aab0f779c0c574897fb6bd6f67f9d722c9ac2 /Build/source/libs/zlib/Makefile.am
parent207e0fee56e671a0913674ee3f71701bb9d84768 (diff)
new build system
git-svn-id: svn://tug.org/texlive/trunk@12446 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/zlib/Makefile.am')
-rw-r--r--Build/source/libs/zlib/Makefile.am68
1 files changed, 68 insertions, 0 deletions
diff --git a/Build/source/libs/zlib/Makefile.am b/Build/source/libs/zlib/Makefile.am
new file mode 100644
index 00000000000..da85df6b5ed
--- /dev/null
+++ b/Build/source/libs/zlib/Makefile.am
@@ -0,0 +1,68 @@
+## Proxy Makefile.am to build zlib for TeX Live.
+##
+## Copyright (C) 2009 Peter Breitenlohner <tex-live@tug.org>
+##
+## This file is free software; the copyright holder
+## gives unlimited permission to copy and/or distribute it,
+## with or without modifications, as long as this notice is preserved.
+##
+ACLOCAL_AMFLAGS = -I ../../m4
+
+## We want to re-distribute the whole original zlib source tree.
+##
+## With current automake (1.10.2) 'make distcheck' fails when
+## DISTFILES contains a directory and files in that directory.
+## Thus nodist_* for all files in $(ZLIB_TREE).
+EXTRA_DIST = $(ZLIB_TREE)
+
+INCLUDES = -I$(top_srcdir)/$(ZLIB_TREE)
+AM_CPPFLAGS = $(ZLIB_DEFINES)
+
+if build
+
+noinst_LIBRARIES = libz.a
+
+BUILT_SOURCES = zconf.h
+
+check_PROGRAMS = example minigzip
+dist_check_SCRIPTS = zlib.test
+
+TESTS = zlib.test
+
+endif build
+
+nodist_libz_a_SOURCES = \
+ $(ZLIB_TREE)/adler32.c \
+ $(ZLIB_TREE)/compress.c \
+ $(ZLIB_TREE)/crc32.c \
+ $(ZLIB_TREE)/crc32.h \
+ $(ZLIB_TREE)/deflate.c \
+ $(ZLIB_TREE)/deflate.h \
+ $(ZLIB_TREE)/gzio.c \
+ $(ZLIB_TREE)/infback.c \
+ $(ZLIB_TREE)/inffast.c \
+ $(ZLIB_TREE)/inffast.h \
+ $(ZLIB_TREE)/inffixed.h \
+ $(ZLIB_TREE)/inflate.c \
+ $(ZLIB_TREE)/inflate.h \
+ $(ZLIB_TREE)/inftrees.c \
+ $(ZLIB_TREE)/inftrees.h \
+ $(ZLIB_TREE)/trees.c \
+ $(ZLIB_TREE)/trees.h \
+ $(ZLIB_TREE)/uncompr.c \
+ $(ZLIB_TREE)/zutil.h \
+ $(ZLIB_TREE)/zutil.c
+
+LDADD = libz.a
+
+nodist_example_SOURCES = $(ZLIB_TREE)/example.c
+nodist_minigzip_SOURCES = $(ZLIB_TREE)/minigzip.c
+
+zconf.h: $(ZLIB_TREE)/zconf.in.h Makefile
+ sed < $< '/HAVE_UNISTD_H/s%^#if [01]%#if $(WITH_UNISTD)%' >$@
+
+DISTCLEANFILES = zconf.h
+
+## Files generated by TESTS
+CLEANFILES = foo.gz foo_gz
+