summaryrefslogtreecommitdiff
path: root/Build/source/libs/libpng/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2009-03-20 08:07:15 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2009-03-20 08:07:15 +0000
commitb89093a4be8467433b6dbabfa09b57e213a53fe0 (patch)
tree6f4fb6eecce8905febf68c34d5926699790466e1 /Build/source/libs/libpng/Makefile.am
parent10d837d22d7d99b26f44847f92501f6037da4ec2 (diff)
new build system
git-svn-id: svn://tug.org/texlive/trunk@12451 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/libpng/Makefile.am')
-rw-r--r--Build/source/libs/libpng/Makefile.am60
1 files changed, 60 insertions, 0 deletions
diff --git a/Build/source/libs/libpng/Makefile.am b/Build/source/libs/libpng/Makefile.am
new file mode 100644
index 00000000000..c12199fd5ed
--- /dev/null
+++ b/Build/source/libs/libpng/Makefile.am
@@ -0,0 +1,60 @@
+## Proxy Makefile.am to build libpng for TeX Live.
+##
+## Copyright (C) 2009 Peter Breitenlohner <tex-live@tug.org>
+##
+## This file is free software; the copyright holder
+## gives unlimited permission to copy and/or distribute it,
+## with or without modifications, as long as this notice is preserved.
+##
+ACLOCAL_AMFLAGS = -I ../../m4
+
+## We want to re-distribute the whole original libpng source tree.
+##
+## With current automake (1.10.2) 'make distcheck' fails when
+## DISTFILES contains a directory and files in that directory.
+## Thus nodist_* for all files in $(LIBPNG_TREE).
+EXTRA_DIST = $(LIBPNG_TREE)
+
+INCLUDES = -I$(top_srcdir)/$(LIBPNG_TREE) $(ZLIB_INCLUDES)
+AM_CPPFLAGS = $(LIBPNG_DEFINES)
+
+if build
+
+noinst_LIBRARIES=libpng.a
+
+TESTS_ENVIRONMENT = LIBPNG_TREE=$(LIBPNG_TREE)
+
+check_PROGRAMS = pngtest
+dist_check_SCRIPTS = libpng.test
+
+endif build
+
+TESTS = libpng.test
+
+nodist_libpng_a_SOURCES = \
+ $(LIBPNG_TREE)/png.c \
+ $(LIBPNG_TREE)/pngset.c \
+ $(LIBPNG_TREE)/pngget.c \
+ $(LIBPNG_TREE)/pngrutil.c \
+ $(LIBPNG_TREE)/pngtrans.c \
+ $(LIBPNG_TREE)/pngwutil.c \
+ $(LIBPNG_TREE)/pngread.c \
+ $(LIBPNG_TREE)/pngrio.c \
+ $(LIBPNG_TREE)/pngwio.c \
+ $(LIBPNG_TREE)/pngwrite.c \
+ $(LIBPNG_TREE)/pngrtran.c \
+ $(LIBPNG_TREE)/pngwtran.c \
+ $(LIBPNG_TREE)/pngmem.c \
+ $(LIBPNG_TREE)/pngerror.c \
+ $(LIBPNG_TREE)/pngpread.c
+
+libpng_a_DEPENDENCIES = $(ZLIB_DEPEND)
+
+## Rebuild zlib
+@ZLIB_RULE@
+
+CLEANFILES = pngout.png
+
+nodist_pngtest_SOURCES = $(LIBPNG_TREE)/pngtest.c
+pngtest_LDADD = libpng.a $(ZLIB_LIBS)
+