summaryrefslogtreecommitdiff
path: root/Build/source/libs/harfbuzz/harfbuzz-src/configure.ac
diff options
context:
space:
mode:
authorAkira Kakuto <kakuto@fuk.kindai.ac.jp>2021-04-17 22:31:16 +0000
committerAkira Kakuto <kakuto@fuk.kindai.ac.jp>2021-04-17 22:31:16 +0000
commit3c7186e871ece5a0ffae02338cfe3081c7716336 (patch)
treeefe91eb855f4131ac94d792252f4e5cb211ff484 /Build/source/libs/harfbuzz/harfbuzz-src/configure.ac
parent2ebe0bc33abc8b1dbe41744fe2d736b196ed2e51 (diff)
harfbuzz 2.8.0
git-svn-id: svn://tug.org/texlive/trunk@58898 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/harfbuzz/harfbuzz-src/configure.ac')
-rw-r--r--Build/source/libs/harfbuzz/harfbuzz-src/configure.ac41
1 files changed, 1 insertions, 40 deletions
diff --git a/Build/source/libs/harfbuzz/harfbuzz-src/configure.ac b/Build/source/libs/harfbuzz/harfbuzz-src/configure.ac
index 2e16b486169..d7f1e2673e2 100644
--- a/Build/source/libs/harfbuzz/harfbuzz-src/configure.ac
+++ b/Build/source/libs/harfbuzz/harfbuzz-src/configure.ac
@@ -1,6 +1,6 @@
AC_PREREQ([2.64])
AC_INIT([HarfBuzz],
- [2.7.4],
+ [2.8.0],
[https://github.com/harfbuzz/harfbuzz/issues/new],
[harfbuzz],
[http://harfbuzz.org/])
@@ -417,45 +417,6 @@ AM_CONDITIONAL(HAVE_CORETEXT, $have_coretext)
dnl ===========================================================================
-AC_CACHE_CHECK([for Intel atomic primitives], hb_cv_have_intel_atomic_primitives, [
- hb_cv_have_intel_atomic_primitives=false
- AC_TRY_LINK([
- void memory_barrier (void) { __sync_synchronize (); }
- int atomic_add (int *i) { return __sync_fetch_and_add (i, 1); }
- int mutex_trylock (int *m) { return __sync_lock_test_and_set (m, 1); }
- void mutex_unlock (int *m) { __sync_lock_release (m); }
- ], [], hb_cv_have_intel_atomic_primitives=true
- )
-])
-if $hb_cv_have_intel_atomic_primitives; then
- AC_DEFINE(HAVE_INTEL_ATOMIC_PRIMITIVES, 1, [Have Intel __sync_* atomic primitives])
-fi
-
-dnl ===========================================================================
-
-AC_CACHE_CHECK([for Solaris atomic operations], hb_cv_have_solaris_atomic_ops, [
- hb_cv_have_solaris_atomic_ops=false
- AC_TRY_LINK([
- #include <atomic.h>
- /* This requires Solaris Studio 12.2 or newer: */
- #include <mbarrier.h>
- void memory_barrier (void) { __machine_rw_barrier (); }
- int atomic_add (volatile unsigned *i) { return atomic_add_int_nv (i, 1); }
- void *atomic_ptr_cmpxchg (volatile void **target, void *cmp, void *newval) { return atomic_cas_ptr (target, cmp, newval); }
- ], [], hb_cv_have_solaris_atomic_ops=true
- )
-])
-if $hb_cv_have_solaris_atomic_ops; then
- AC_DEFINE(HAVE_SOLARIS_ATOMIC_OPS, 1, [Have Solaris __machine_*_barrier and atomic_* operations])
-fi
-
-if test "$os_win32" = no && ! $have_pthread; then
- AC_CHECK_HEADERS(sched.h)
- AC_SEARCH_LIBS(sched_yield,rt,AC_DEFINE(HAVE_SCHED_YIELD, 1, [Have sched_yield]))
-fi
-
-dnl ===========================================================================
-
AC_CONFIG_FILES([
Makefile
src/Makefile