summaryrefslogtreecommitdiff
path: root/Build/source/libs/gd/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2009-11-20 14:50:55 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2009-11-20 14:50:55 +0000
commit5d60f08750b360f416400d95fe18157aee0e4f88 (patch)
treed94591a0d8dedc5d0d8b086690a8aec3ad4cebb7 /Build/source/libs/gd/Makefile.am
parentab69232c2ed5d07fd7dfc8e49b3003dbd1f0ca16 (diff)
build system: libs/gd/ reorg
git-svn-id: svn://tug.org/texlive/trunk@16104 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/gd/Makefile.am')
-rw-r--r--Build/source/libs/gd/Makefile.am32
1 files changed, 3 insertions, 29 deletions
diff --git a/Build/source/libs/gd/Makefile.am b/Build/source/libs/gd/Makefile.am
index 630edfe0f0a..8da47ee00fe 100644
--- a/Build/source/libs/gd/Makefile.am
+++ b/Build/source/libs/gd/Makefile.am
@@ -39,6 +39,8 @@ dist-hook:
$(distdir)/$(GD_TREE)/missing \
$(distdir)/$(GD_TREE)/mkinstalldirs
+SUBDIRS = include
+
INCLUDES = -I$(top_srcdir)/$(GD_TREE) $(ZLIB_INCLUDES) $(LIBPNG_INCLUDES)
noinst_LIBRARIES=libgd.a
@@ -73,22 +75,7 @@ nodist_libgd_a_SOURCES = \
$(GD_TREE)/gdxpm.c \
$(GD_TREE)/wbmp.c
-BUILT_SOURCES = \
- entities.h \
- gd.h \
- gd_io.h \
- gdcache.h \
- gdfontg.h \
- gdfontl.h \
- gdfontmb.h \
- gdfonts.h \
- gdfontt.h \
- gdfx.h \
- gdhelpers.h \
- jisx0208.h \
- wbmp.h
-
-$(libgd_a_OBJECTS): $(BUILT_SOURCES) config.force
+$(libgd_a_OBJECTS): config.force
config.force: $(ZLIB_DEPEND) $(LIBPNG_DEPEND)
echo timestamp >config.force
@@ -101,16 +88,3 @@ DISTCLEANFILES = config.force
## Rebuild libpng
@LIBPNG_RULE@
-$(BUILT_SOURCES): stamp-gd
-
-stamp-gd:
- @for file in $(BUILT_SOURCES); do \
- test -f $$file || { \
- echo "$(LN_S) $(srcdir)/$(GD_TREE)/$$file $$file"; \
- $(LN_S) $(srcdir)/$(GD_TREE)/$$file $$file; } || exit 1; \
- done
- echo timestamp >$@
-
-distclean-local:
- rm -f stamp-gd $(BUILT_SOURCES)
-