summaryrefslogtreecommitdiff
path: root/Build/source/libs/freetype2/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2012-11-26 08:10:55 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2012-11-26 08:10:55 +0000
commit3c06d717b891d74b66f02b12ba0d4ad0f6437f5c (patch)
tree51bd46e7acd2ce72f2be14de4c9bfe854a47341c /Build/source/libs/freetype2/Makefile.am
parent6650155057159411fc2dddd0ae020266eb3509b5 (diff)
poppler: Require 0.20 or better for POPPLER_VERSION
build system: Better dependencies for parallel builds git-svn-id: svn://tug.org/texlive/trunk@28367 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/freetype2/Makefile.am')
-rw-r--r--Build/source/libs/freetype2/Makefile.am22
1 files changed, 8 insertions, 14 deletions
diff --git a/Build/source/libs/freetype2/Makefile.am b/Build/source/libs/freetype2/Makefile.am
index 5fb9ba4cad8..6f660a049b5 100644
--- a/Build/source/libs/freetype2/Makefile.am
+++ b/Build/source/libs/freetype2/Makefile.am
@@ -14,8 +14,6 @@ rebuild: all
## We want to re-distribute the whole original FreeType source tree.
##
-## With current automake (1.10.2) 'make distcheck' fails when
-## DISTFILES contains a directory and files in that directory.
EXTRA_DIST = $(FREETYPE_TREE)
## Changes applied to the original source tree
@@ -28,7 +26,12 @@ dist-hook:
noinst_DATA = libfreetype.a
-ft-build/Makefile:
+# On MacOSX, using our zlib from TL results in a .a that is unusable; ld
+# warns "file is not of required architecture", and does not read it.
+# There is no apparent reason for this. Using --without-zlib evidently
+# causes freetype2 to use its internal zlib, so no functionality should
+# be lost, even though it is not the cleanest solution.
+ft-config:
rm -rf ft-build
$(MKDIR_P) ft-build
cd ft-build && \
@@ -41,24 +44,15 @@ ft-build/Makefile:
--prefix=$(abs_builddir)/ft-install \
--libdir=$(abs_builddir) \
--includedir=$(abs_builddir)
+ echo timestamp >ft-config
-# On MacOSX, using our zlib from TL results in a .a that is unusable; ld
-# warns "file is not of required architecture", and does not read it.
-# There is no apparent reason for this. Using --without-zlib evidently
-# causes freetype2 to use its internal zlib, so no functionality should
-# be lost, even though it is not the cleanest solution.
-# --with-zlib $(ZLIB_FLAGS_FOR_FREETYPE) \
-#
# Unfortunately the FreeType build system installs the headers after the library;
# to get our dependencies right we wait for a second and then touch the library.
-libfreetype.a: ft-build/Makefile $(ZLIB_DEPEND)
+libfreetype.a: ft-config
rm -rf ft-install
cd ft-build \
&& $(MAKE) $(AM_MAKEFLAGS) \
&& $(MAKE) $(AM_MAKEFLAGS) install
- ft-install/bin/freetype-config --cflags >ft-includes
- ft-install/bin/freetype-config --libs \
- | sed -e 's,-L\(.*\) -lfreetype,\1/libfreetype.la,' >ft-libs
sleep 1
@for f in libfreetype.*; do touch $$f; done