summaryrefslogtreecommitdiff
path: root/Build/source/libs/freetype2/Makefile.am
diff options
context:
space:
mode:
authorKarl Berry <karl@freefriends.org>2021-01-04 00:01:15 +0000
committerKarl Berry <karl@freefriends.org>2021-01-04 00:01:15 +0000
commit1b0ca135b8db6e2711512fdb21fa5eecf3a899a3 (patch)
treea2de03f32ec0128a915d37ac210840aa3dad7c96 /Build/source/libs/freetype2/Makefile.am
parente31347e2e9b55fc186b3af5f8420c5ba555dd87d (diff)
force --without-brotli for freetype config
git-svn-id: svn://tug.org/texlive/trunk@57320 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/freetype2/Makefile.am')
-rw-r--r--Build/source/libs/freetype2/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/Build/source/libs/freetype2/Makefile.am b/Build/source/libs/freetype2/Makefile.am
index 17752d43848..cff55cb1827 100644
--- a/Build/source/libs/freetype2/Makefile.am
+++ b/Build/source/libs/freetype2/Makefile.am
@@ -25,7 +25,9 @@ noinst_DATA = libfreetype.a
# warns "file is not of required architecture", and does not read it.
# There is no apparent reason for this. Using --without-zlib evidently
# causes freetype2 to use its internal zlib, so no functionality should
-# be lost, even though it is not the cleanest solution.
+# be lost, even though it is not the cleanest solution. Similarly, don't
+# incorporate other libraries which are not needed or are elsewhere in TL.
+# They just complicate things.
ft-config:
rm -rf ft-build
$(MKDIR_P) ft-build
@@ -34,9 +36,10 @@ ft-config:
$(SHELL) $(abs_srcdir)/$(FREETYPE_TREE)/configure \
$(config_args) --disable-shared \
--without-bzip2 \
- --without-zlib \
- --without-png \
+ --without-brotli \
--without-harfbuzz \
+ --without-png \
+ --without-zlib \
--prefix=$(abs_builddir)/ft-install \
--libdir=$(abs_builddir) \
--includedir=$(abs_builddir)