summaryrefslogtreecommitdiff
path: root/Build/source/libs/freetype2/Makefile.am
diff options
context:
space:
mode:
authorKarl Berry <karl@freefriends.org>2009-04-17 00:01:04 +0000
committerKarl Berry <karl@freefriends.org>2009-04-17 00:01:04 +0000
commita59811571ec98d9930b16db1213daf261e6eed78 (patch)
tree5361bee7937d42c9a1bcf5ec63a769667ebd37b2 /Build/source/libs/freetype2/Makefile.am
parentf4d9fc4c712731965cb59f8cad65f00d2e2815c3 (diff)
use --without-zlib instead of the TL zlib, to avoid strange warning "file is not of required architecture" from MacOSX ld, and consequent failure
git-svn-id: svn://tug.org/texlive/trunk@12737 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/freetype2/Makefile.am')
-rw-r--r--Build/source/libs/freetype2/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Build/source/libs/freetype2/Makefile.am b/Build/source/libs/freetype2/Makefile.am
index 39c931bb58b..49f9b63ef3a 100644
--- a/Build/source/libs/freetype2/Makefile.am
+++ b/Build/source/libs/freetype2/Makefile.am
@@ -31,10 +31,18 @@ ft-build/Makefile:
$(abs_srcdir)/$(FREETYPE_TREE)/configure \
$(config_args) --disable-shared \
--with-old-mac-fonts \
- --with-zlib $(ZLIB_FLAGS_FOR_FREETYPE) \
+ --without-zlib \
--prefix=$(abs_builddir)/ft-install \
--includedir=$(abs_builddir)
+# On MacOSX, using our zlib from TL results in a .a that is unusable; ld
+# warns "file is not of required architecture", and does not read it.
+# There is no apparent reason for this. Using --without-zlib evidently
+# causes freetype2 to use its internal zlib, so no functionality should
+# be lost, even though it is not the cleanest solution.
+# --with-zlib $(ZLIB_FLAGS_FOR_FREETYPE) \
+#
+
## Unfortunately the FreeType build system installs the headers after the library;
## get our dependencies right we wait for a second and then touch the library.
libfreetype.a: ft-build/Makefile $(ZLIB_DEPEND)