summaryrefslogtreecommitdiff
path: root/Build/source/extra/xz/tests/Makefile.am
diff options
context:
space:
mode:
authorKarl Berry <karl@freefriends.org>2010-06-13 22:23:34 +0000
committerKarl Berry <karl@freefriends.org>2010-06-13 22:23:34 +0000
commitf06e0d7e9489163b444e1381a9e670ed1789725d (patch)
treed838b80e2b32cea0554b0a238b8344fe8059b4ad /Build/source/extra/xz/tests/Makefile.am
parent686b7eed06371a6d8721b657c0e77207732172dc (diff)
rename to plain xz for the sake of diffs and consistent path in doc
git-svn-id: svn://tug.org/texlive/trunk@18954 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/extra/xz/tests/Makefile.am')
-rw-r--r--Build/source/extra/xz/tests/Makefile.am51
1 files changed, 51 insertions, 0 deletions
diff --git a/Build/source/extra/xz/tests/Makefile.am b/Build/source/extra/xz/tests/Makefile.am
new file mode 100644
index 00000000000..d01787a37ad
--- /dev/null
+++ b/Build/source/extra/xz/tests/Makefile.am
@@ -0,0 +1,51 @@
+##
+## Author: Lasse Collin
+##
+## This file has been put into the public domain.
+## You can do whatever you want with this file.
+##
+
+EXTRA_DIST = \
+ files \
+ tests.h \
+ test_files.sh \
+ test_compress.sh \
+ bcj_test.c \
+ compress_prepared_bcj_sparc \
+ compress_prepared_bcj_x86
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/src/common \
+ -I$(top_srcdir)/src/liblzma/api \
+ -I$(top_builddir)/lib \
+ $(STATIC_CPPFLAGS)
+
+AM_LDFLAGS = $(STATIC_LDFLAGS)
+
+LDADD = $(top_builddir)/src/liblzma/liblzma.la
+
+if COND_GNULIB
+LDADD += $(top_builddir)/lib/libgnu.a
+endif
+
+LDADD += $(LTLIBINTL)
+
+check_PROGRAMS = \
+ create_compress_files \
+ test_check \
+ test_stream_flags \
+ test_filter_flags \
+ test_block_header \
+ test_index
+
+TESTS = \
+ test_check \
+ test_stream_flags \
+ test_filter_flags \
+ test_block_header \
+ test_index \
+ test_files.sh \
+ test_compress.sh
+
+clean-local:
+ -rm -f compress_generated_*