summaryrefslogtreecommitdiff
path: root/Build/source/extra/xz/lib/Makefile.am
diff options
context:
space:
mode:
authorKarl Berry <karl@freefriends.org>2010-06-13 22:23:34 +0000
committerKarl Berry <karl@freefriends.org>2010-06-13 22:23:34 +0000
commitf06e0d7e9489163b444e1381a9e670ed1789725d (patch)
treed838b80e2b32cea0554b0a238b8344fe8059b4ad /Build/source/extra/xz/lib/Makefile.am
parent686b7eed06371a6d8721b657c0e77207732172dc (diff)
rename to plain xz for the sake of diffs and consistent path in doc
git-svn-id: svn://tug.org/texlive/trunk@18954 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/extra/xz/lib/Makefile.am')
-rw-r--r--Build/source/extra/xz/lib/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/Build/source/extra/xz/lib/Makefile.am b/Build/source/extra/xz/lib/Makefile.am
new file mode 100644
index 00000000000..0dbd9c42b72
--- /dev/null
+++ b/Build/source/extra/xz/lib/Makefile.am
@@ -0,0 +1,32 @@
+##
+## Copyright (C) 2004-2007 Free Software Foundation, Inc.
+##
+## This program is free software; you can redistribute it and/or modify
+## it under the terms of the GNU General Public License as published by
+## the Free Software Foundation; either version 2 of the License, or
+## (at your option) any later version.
+##
+## This program is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+## GNU General Public License for more details.
+##
+
+## Not using gnulib-tool, at least for now. It is likely that we won't
+## need anything else from Gnulib than getopt_long().
+
+noinst_LIBRARIES = libgnu.a
+
+libgnu_a_SOURCES =
+libgnu_a_DEPENDENCIES = $(LIBOBJS)
+libgnu_a_LIBADD = $(LIBOBJS)
+
+EXTRA_DIST = getopt.in.h getopt.c getopt1.c getopt_int.h
+BUILT_SOURCES = $(GETOPT_H)
+MOSTLYCLEANFILES = getopt.h getopt.h-t
+
+getopt.h: getopt.in.h
+ { echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */'; \
+ cat $(srcdir)/getopt.in.h; \
+ } > $@-t
+ mv -f $@-t $@