summaryrefslogtreecommitdiff
path: root/Build/source/configure.in
diff options
context:
space:
mode:
authorKarl Berry <karl@freefriends.org>2006-07-09 22:44:40 +0000
committerKarl Berry <karl@freefriends.org>2006-07-09 22:44:40 +0000
commit6684474324a04b457fe7019684c42eb68c4fea4b (patch)
tree63f0520f448252eb06342d5e0ea8e700c4976136 /Build/source/configure.in
parentbb92d19047f4437f2d13091072ec63a5641dc43c (diff)
new graphics utility sam2p
git-svn-id: svn://tug.org/texlive/trunk@1792 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/configure.in')
-rw-r--r--Build/source/configure.in11
1 files changed, 9 insertions, 2 deletions
diff --git a/Build/source/configure.in b/Build/source/configure.in
index 97ff6747b2a..89d3c2ca62b 100644
--- a/Build/source/configure.in
+++ b/Build/source/configure.in
@@ -192,14 +192,21 @@ test "$needs_freetype" = yes && test "$using_system_freetype" != yes \
AC_CONFIG_SUBDIRS([libs])
-PKGS='dialog lcdf-typetools pdfopen psutils t1utils texi2html texinfo'
+PKGS='dialog lcdf-typetools pdfopen psutils sam2p t1utils texi2html texinfo'
ESUBDIRS=
+test -d utils || mkdir utils
for pkg in $PKGS; do
if test -d $srcdir/utils/$pkg; then
if eval "test \"`echo '$with_'${pkg}`\" != no"; then
ESUBDIRS="$ESUBDIRS utils/$pkg"
+ if test $pkg = sam2p; then
+ # this is a terrible kludge, but sam2p configure actively
+ # defeats srcdir!=objdir support, and Peter S. doesn't want to
+ # fix it. So copy the entire sam2p srcdir into objdir.
+ rm -rf utils/sam2p
+ cp -pr $srcdir/utils/sam2p utils
+ fi
AC_CONFIG_SUBDIRS([utils/$pkg])
- test -d utils || mkdir utils
fi
fi
done