summaryrefslogtreecommitdiff
path: root/Build/source/configure.in
diff options
context:
space:
mode:
authorKarl Berry <karl@freefriends.org>2006-08-21 22:49:11 +0000
committerKarl Berry <karl@freefriends.org>2006-08-21 22:49:11 +0000
commit1cb8d5ae6bdcf8306ed1bc0da315dcb83356d189 (patch)
treef5720835f9e22250c41750542089716816e57de8 /Build/source/configure.in
parent0b8cf78188f48679352623a282be40fa0dafcdd6 (diff)
do not copy if srcdir=builddir
git-svn-id: svn://tug.org/texlive/trunk@1998 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/configure.in')
-rw-r--r--Build/source/configure.in15
1 files changed, 10 insertions, 5 deletions
diff --git a/Build/source/configure.in b/Build/source/configure.in
index 049f1fedf5d..e7f38739d7c 100644
--- a/Build/source/configure.in
+++ b/Build/source/configure.in
@@ -236,11 +236,16 @@ for pkg in $PKGS; do
if eval "test \"`echo '$with_'${pkg}|sed 's/-/_/g'`\" != no"; then
ESUBDIRS="$ESUBDIRS utils/$pkg"
if test $pkg = sam2p; then
- # this is a terrible kludge, but sam2p configure actively
- # defeats srcdir!=objdir support, and Peter S. doesn't want to
- # fix it. So copy the entire sam2p srcdir into objdir.
- rm -rf utils/sam2p
- cp -pr $srcdir/utils/sam2p utils
+ # attempt to discover if srcdir = builddir.
+ dir1=`cd $srcdir/utils/sam2p && /bin/pwd`
+ dir2=`cd utils/sam2p && /bin/pwd`
+ if test "$dir1" != "$dir2"; then
+ # this is a terrible kludge, but sam2p configure actively
+ # defeats srcdir!=objdir support, and Peter S. doesn't want to
+ # fix it. So copy the entire sam2p srcdir into objdir.
+ rm -rf utils/sam2p
+ cp -pr $srcdir/utils/sam2p utils
+ fi
fi
AC_CONFIG_SUBDIRS([utils/$pkg])
fi