summaryrefslogtreecommitdiff
path: root/Build/source/Makefile.am
diff options
context:
space:
mode:
authorKarl Berry <karl@freefriends.org>2019-06-06 22:21:33 +0000
committerKarl Berry <karl@freefriends.org>2019-06-06 22:21:33 +0000
commitb1f25da6362d2bb38aa5b1eaea73a4609b0c906b (patch)
tree799a16a4f0005dd1f676064f99caa6b5ab9d5a51 /Build/source/Makefile.am
parenta49413506f5b7b1cf775e17dc08cf373a9db023b (diff)
build-info.sh script to create Work/buildinfo.log
git-svn-id: svn://tug.org/texlive/trunk@51335 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/Makefile.am')
-rw-r--r--Build/source/Makefile.am27
1 files changed, 21 insertions, 6 deletions
diff --git a/Build/source/Makefile.am b/Build/source/Makefile.am
index 388c89aed78..dee82b40479 100644
--- a/Build/source/Makefile.am
+++ b/Build/source/Makefile.am
@@ -42,25 +42,40 @@ recurse_top =
include $(srcdir)/am/recurse.am
-# This is the default target for the Build script in TeX Live.
+# This (world) is the default target for the ./Build script in TeX Live.
.PHONY: world
# Run texlinks here since the binaries won't be there
# at install-data, and fmtutil.cnf won't be there at install-exec,
# and there is no install-hook or install-local.
texlinks_dir = texk/texlive/tl_scripts
world: all
-## Serialize 'make all' and 'make install-strip'.
+ @echo "top-level make $@: running $(build_info_target)..."
+ $(MAKE) $(AM_MAKEFLAGS) $(build_info_target)
+#
+# Serialize 'make all' and 'make install-strip'.
@echo "top-level make $@: running install-strip..."
$(MAKE) $(AM_MAKEFLAGS) install-strip
-##
- @echo "top-level make $@: running texlinks in $(texlinks_dir) ..."
+#
+ @echo "top-level make $@: making run-texlinks in $(texlinks_dir) ..."
cd $(texlinks_dir) && $(MAKE) $(AM_MAKEFLAGS) run-texlinks
-##
+#
@echo "top-level make $@: running $(check_target)..."
$(MAKE) $(AM_MAKEFLAGS) $(check_target)
-##
+#
@echo "top-level make $@ done."
+# create file buildinfo.log in working directory, to record relevant
+# information about the build environment.
+build-info:
+ -env MAKE="$(MAKE)" LDFLAGS="$(LDFLAGS)" \
+ CC="$(CC)" CFLAGS="$(CFLAGS)" \
+ CXX="$(CXX)" CXXFLAGS="$(CXXFLAGS)" \
+ OBJC="$(OBJC)" OBJCXXFLAGS="$(OBJCXXFLAGS)" \
+ $(srcdir)/doc/build-info.sh >buildinfo.log
+
+# should be harmless to run that, but just in case:
+build_info_target = build-info
+
install-exec-hook:
@echo "WARNING: make install does not result in a usable TeX!"
@echo " ! The binaries require the myriad support files."