summaryrefslogtreecommitdiff
path: root/Build/source/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2013-07-07 14:29:53 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2013-07-07 14:29:53 +0000
commit0df6dd4d8aea6edc733de81fb7eec115ea59a36e (patch)
treee2f7056cb53c58c8ef5779450ac468091b2bd86d /Build/source/Makefile.am
parent3675a91dd83af3eaa1c1a12e91af1e6c86f710f8 (diff)
build system: additional Makefile fragments
better handling of dependencies for highly parallel make git-svn-id: svn://tug.org/texlive/trunk@31127 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/Makefile.am')
-rw-r--r--Build/source/Makefile.am52
1 files changed, 7 insertions, 45 deletions
diff --git a/Build/source/Makefile.am b/Build/source/Makefile.am
index dcec116f3af..e328bf1dab6 100644
--- a/Build/source/Makefile.am
+++ b/Build/source/Makefile.am
@@ -30,58 +30,20 @@ EXTRA_DIST = \
dist-hook:
rm -rf `find $(distdir) -name .svn`
-CONFIG_AUX = subsubdir-conf.cmd
-
-SUBDIRS = . $(TEXLIBS) libs utils texk
-DIST_SUBDIRS = auxdir/auxsub $(DIST_TEXLIBS) libs utils texk
+SUBDIRS = . $(MAKE_SUBDIRS) libs utils texk
+DIST_SUBDIRS = auxdir/auxsub $(CONF_SUBDIRS) libs utils texk
cf_silent = $(cf_silent_@AM_V@)
cf_silent_ = $(cf_silent_@AM_DEFAULT_V@)
cf_silent_0 = --silent
cf_silent_1 =
-all-local: texlibs
-
-.PHONY: texlibs
-# We must configure all texk subdirs since 'make dist' needs the Makefile.
-# For those not required for the current set of configure options
-# we append '--disable-build' so they can skip tests that would
-# fail because other libraries were not built.
-#
-# Sequentially configure and optionally build all texk libraries;
-# code inspired by automake's way to handle recursive targets.
-texlibs: $(CONFIG_AUX)
- @fail= failcom='exit 1'; \
- for f in x $$MAKEFLAGS; do \
- case $$f in \
- *=* | --[!k]*);; \
- *k*) failcom='fail=yes';; \
- esac; \
- done; \
- list='$(DIST_TEXLIBS)'; for texlibs in $$list; do \
- if test ! -f $$texlibs/Makefile; then \
- test -d $$texlibs || $(MKDIR_P) $$texlibs; \
- cmd=`cat $(CONFIG_AUX) | sed "s,auxdir/auxsub,$$texlibs,g"`; \
- case " $(TEXLIBS) " in \
- *" $$texlibs "*) skip=;; \
- *) skip=' --disable-build';; \
- esac; \
- (cd $$texlibs && echo "=== configuring in $$texlibs (`pwd`)" && \
- if $(AM_V_P); then echo "make: running $(SHELL) $$cmd$$skip"; fi && \
- CONFIG_SHELL=$(SHELL) && export CONFIG_SHELL && \
- eval $(SHELL) $$cmd$$skip $(cf_silent) || \
- { echo "=== configuring in $$texlibs failed"; exit 1; }) && \
- if test "x$$skip" = x; then \
- echo "Making all in $$texlibs" && \
- (cd $$texlibs && $(MAKE) $(AM_MAKEFLAGS) all); \
- fi || eval $$failcom; \
- fi; \
- done; test -z "$$fail"
-
-subsubdir-conf.cmd:
- @echo "configure in auxdir/auxsub failed to create the file $@"
- exit 1
+## Configure and build subdirs.
+##
+recurse_this =
+recurse_top =
+include $(srcdir)/am/recurse.am
# This is the default target for the Build script in TeX Live.
.PHONY: world