summaryrefslogtreecommitdiff
path: root/support/intex/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'support/intex/src/Makefile.am')
-rw-r--r--support/intex/src/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/support/intex/src/Makefile.am b/support/intex/src/Makefile.am
new file mode 100644
index 0000000000..d80c098482
--- /dev/null
+++ b/support/intex/src/Makefile.am
@@ -0,0 +1,12 @@
+
+bin_SCRIPTS = mkintex
+CLEANFILES = $(bin_SCRIPTS)
+
+do_subst = sed -e 's,[@]datadir[@],$(datadir),g' \
+ -e 's,[@]PYTHON[@],$(PYTHON),g' \
+ -e 's,[@]PACKAGE[@],$(PACKAGE),g' \
+ -e 's,[@]VERSION[@],$(VERSION),g'
+
+mkintex: mkintex.py Makefile
+ $(do_subst) <$< >$@
+ chmod +x $@