summaryrefslogtreecommitdiff
path: root/obsolete/language/thai/thailatex/hyphen/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'obsolete/language/thai/thailatex/hyphen/Makefile.am')
-rw-r--r--obsolete/language/thai/thailatex/hyphen/Makefile.am75
1 files changed, 75 insertions, 0 deletions
diff --git a/obsolete/language/thai/thailatex/hyphen/Makefile.am b/obsolete/language/thai/thailatex/hyphen/Makefile.am
new file mode 100644
index 0000000000..483b20d379
--- /dev/null
+++ b/obsolete/language/thai/thailatex/hyphen/Makefile.am
@@ -0,0 +1,75 @@
+hyphendir = $(texmfdir)/tex/generic/$(PACKAGE)
+hyphen_DATA = loadhyph-th.tex hyph-th.tex hyph-th-utf8.tex
+
+TDICT_SRC = \
+ $(srcdir)/tdict-common.txt \
+ $(srcdir)/tdict-collection.txt \
+ $(srcdir)/tdict-district.txt \
+ $(srcdir)/tdict-city.txt \
+ $(srcdir)/tdict-country.txt \
+ $(srcdir)/tdict-geo.txt \
+ $(srcdir)/tdict-history.txt \
+ $(srcdir)/tdict-ict.txt \
+ $(srcdir)/tdict-lang-ethnic.txt \
+ $(srcdir)/tdict-proper.txt \
+ $(srcdir)/tdict-science.txt \
+ $(srcdir)/tdict-spell.txt \
+ $(srcdir)/tdict-std.txt \
+ $(srcdir)/tdict-std-compound.txt
+
+EXTRA_DIST = \
+ README \
+ loadhyph-th.tex \
+ hyph-th.tex.in \
+ hyph-th-utf8.tex.in \
+ thai.tra \
+ thai-exc.pat \
+ conv-utf8-hex.sed \
+ test-hyphen.sh \
+ diff-dicts.sh \
+ $(TDICT_SRC)
+
+PATGEN_ANS = \
+1 5 \n\
+2 5 \n\
+1 2 10 \n\
+1 6 \n\
+2 1 8 \n\
+3 8 \n\
+1 4 5 \n\
+3 10 \n\
+3 2 1 \n\
+4 11 \n\
+1 10 1 \n\
+y
+
+thai.dic: $(TDICT_SRC)
+ cat $(TDICT_SRC) | LC_ALL=C sort -u > $@
+
+thai.out: thai.dic thai.tra
+ rm -f thai.pat
+ touch thai.pat
+ printf "$(PATGEN_ANS)" \
+ | $(PATGEN) thai.dic thai.pat thai.out $(srcdir)/thai.tra
+
+thai-comb.pat: thai.out thai-exc.pat
+ cat thai.out $(srcdir)/thai-exc.pat > $@
+
+hyph-th-utf8.tex: thai-comb.pat hyph-th-utf8.tex.in
+ $(AWK) "BEGIN {show=1} /@PATTERNS@/ {show=0} {if(show) print}" \
+ $(srcdir)/hyph-th-utf8.tex.in > $@
+ cat thai-comb.pat >> $@
+ $(AWK) "BEGIN {show=0;pat=0} /@PATTERNS@/ {pat=1} {if(show) print; if(pat) show=1}" \
+ $(srcdir)/hyph-th-utf8.tex.in >> $@
+
+hyph-th.tex: thai-comb.pat conv-utf8-hex.sed hyph-th.tex.in
+ $(AWK) "BEGIN {show=1} /@PATTERNS@/ {show=0} {if(show) print}" \
+ $(srcdir)/hyph-th.tex.in > $@
+ $(SED) -f $(srcdir)/conv-utf8-hex.sed thai-comb.pat >> $@
+ $(AWK) "BEGIN {show=0;pat=0} /@PATTERNS@/ {pat=1} {if(show) print; if(pat) show=1}" \
+ $(srcdir)/hyph-th.tex.in >> $@
+
+CLEANFILES = \
+ thai.dic thai.pat pattmp.* thai.out thai-comb.pat \
+ hyph-th.tex hyph-th-utf8.tex
+