summaryrefslogtreecommitdiff
path: root/support/ligatex/configure.in
diff options
context:
space:
mode:
authorNorbert Preining <norbert@preining.info>2019-09-02 13:46:59 +0900
committerNorbert Preining <norbert@preining.info>2019-09-02 13:46:59 +0900
commite0c6872cf40896c7be36b11dcc744620f10adf1d (patch)
tree60335e10d2f4354b0674ec22d7b53f0f8abee672 /support/ligatex/configure.in
Initial commit
Diffstat (limited to 'support/ligatex/configure.in')
-rwxr-xr-xsupport/ligatex/configure.in29
1 files changed, 29 insertions, 0 deletions
diff --git a/support/ligatex/configure.in b/support/ligatex/configure.in
new file mode 100755
index 0000000000..a22fdca06c
--- /dev/null
+++ b/support/ligatex/configure.in
@@ -0,0 +1,29 @@
+dnl Process this file with autoconf to produce a configure script.
+AC_INIT(ligatex.l)
+
+dnl We only want to use flex, not any other lex, because the files in this
+dnl distribution are too big for non-flex lex implementations.
+AC_CHECK_PROG(LEX, flex, flex, lose)
+if test $ac_cv_prog_LEX = lose; then
+ echo flex not found
+ exit 1
+fi
+
+dnl Checks for programs.
+AC_PROG_INSTALL
+AC_PROG_CC
+
+dnl Checks for libraries.
+
+AC_CHECK_LIB(l, main)
+
+dnl Checks for header files.
+AC_HEADER_STDC
+AC_CHECK_HEADERS(unistd.h)
+
+dnl Checks for typedefs, structures, and compiler characteristics.
+AC_C_CONST
+
+dnl Checks for library functions.
+
+AC_OUTPUT(Makefile)