summaryrefslogtreecommitdiff
path: root/support/intex/Makefile.am
diff options
context:
space:
mode:
authorNorbert Preining <norbert@preining.info>2019-09-02 13:46:59 +0900
committerNorbert Preining <norbert@preining.info>2019-09-02 13:46:59 +0900
commite0c6872cf40896c7be36b11dcc744620f10adf1d (patch)
tree60335e10d2f4354b0674ec22d7b53f0f8abee672 /support/intex/Makefile.am
Initial commit
Diffstat (limited to 'support/intex/Makefile.am')
-rw-r--r--support/intex/Makefile.am51
1 files changed, 51 insertions, 0 deletions
diff --git a/support/intex/Makefile.am b/support/intex/Makefile.am
new file mode 100644
index 0000000000..4ff1c4a6ed
--- /dev/null
+++ b/support/intex/Makefile.am
@@ -0,0 +1,51 @@
+# Copyright (C) 2007 by Martin Thorsen Ranang
+#
+# $Id$
+#
+SUBDIRS = src latex doc
+
+ACLOCAL_AMFLAGS = -I m4
+
+EXTRA_DIST = config.rpath m4/ChangeLog m4/ChangeLog src/*.py #lib/
+
+pysetyp = setup.py
+
+PYTHON = /usr/bin/python2.7
+
+GET_RELEASE = $(top_srcdir)/bin/get_release
+
+RELEASE := $(shell $(GET_RELEASE))
+
+DISTDIR = $(top_srcdir)/dist
+
+release:
+ $(top_srcdir)/bin/get_release
+
+next_release:
+ $(top_srcdir)/bin/increase_release
+
+tag_release:
+ $(top_srcdir)/bin/tag_release
+
+rpm_sign:
+ rpmsign --addsign $(DISTDIR)/$(PACKAGE)-$(VERSION)-$(RELEASE).*.rpm
+
+# rpm: all release tag_release $(pysetyp)
+rpm: all release $(pysetyp)
+ @python $(pysetyp) clean
+ @python $(pysetyp) bdist_rpm --python=$(PYTHON) --release=$(RELEASE) --post-install=$(top_srcdir)/src/post-install.sh --post-uninstall=$(top_srcdir)/src/post-uninstall.sh
+
+deb_sign: deb
+ pushd $(DISTDIR) && dpkg-sig --sign builder $(PACKAGE)_$(VERSION)-$(RELEASE)_all.deb && popd
+
+deb: rpm
+ pushd $(DISTDIR) && fakeroot alien --to-deb --keep-version --scripts $(PACKAGE)-$(VERSION)-$(RELEASE).noarch.rpm && popd
+
+tests:
+ PYTHONPATH=$(top_srcdir)/lib pytest test
+
+#etags --language-force=Python
+etags:
+ etags --language=python \
+ src/* \
+ $$(find lib -name \*\.py |tr '\n' ' ')